Bug 1020545 - Some Activities fail to run correctly in F-20 beta
Some Activities fail to run correctly in F-20 beta
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: sugar (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Simon Schampijer
Fedora Extras Quality Assurance
AcceptedFreezeException
:
Depends On:
Blocks: F20BetaFreezeException
  Show dependency treegraph
 
Reported: 2013-10-17 17:22 EDT by Peter Robinson
Modified: 2013-11-08 23:25 EST (History)
8 users (show)

See Also:
Fixed In Version: sugar-record-99-3.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-08 23:24:59 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Robinson 2013-10-17 17:22:35 EDT
When testing TC5 there's a few Sugar Activities that fail to run correctly.

The following updates fix all the current issues with the shipping Activities:

https://admin.fedoraproject.org/updates/sugar-record-99-3.fc20,sugar-memorize-45-3.fc20,sugar-clock-15-3.fc20,sugar-speak-47-3.fc20

https://admin.fedoraproject.org/updates/FEDORA-2013-19091/sugar-portfolio-44-1.fc20

it would be great to get these into Beta for wider testing
Comment 1 Fedora Blocker Bugs Application 2013-10-17 17:31:04 EDT
Proposed as a Freeze Exception for 20-beta by Fedora user pbrobinson using the blocker tracking app because:

 When testing TC5 there's a few Sugar Activities that fail to run correctly.

The Activity updates in the BZ fix all the current issues with the shipping Activities
Comment 2 Mike Ruckman 2013-10-21 13:47:04 EDT
Discussed this in 2013-10-21 Blocker Review Meeting [1]. Accepted as a freeze exception issue as a significant issue in a non-blocking desktop that can't be fixed with an update.

[1] http://meetbot.fedoraproject.org/fedora-blocker-review/2013-10-21/
Comment 3 Fedora Update System 2013-10-26 05:34:13 EDT
sugar-record-99-3.fc20, sugar-memorize-45-3.fc20, sugar-clock-15-3.fc20, sugar-speak-47-3.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/FEDORA-2013-19423/sugar-record-99-3.fc20,sugar-memorize-45-3.fc20,sugar-clock-15-3.fc20,sugar-speak-47-3.fc20
Comment 4 Fedora Update System 2013-10-26 05:34:36 EDT
sugar-portfolio-44-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/FEDORA-2013-19091/sugar-portfolio-44-1.fc20
Comment 5 satellitgo 2013-11-07 07:39:16 EST
Testing RC5 DVD x86_64 install to USB HD:
Activities with errors
Installed with extra activities checked

Many activites error: Couldn't register with accessibility bus: Did not receive a reply........

CHAT 78:
 starts but does not join jabber as shared. Stays on top bar
 no emoticons appear no imput in chat line
 "ValueError: ('Activity %s is already tracked' ,
 
Browse 155:
 Attempt to join a shared browse in f1 goes to normal start screen then refuses to start again afte shutdown have to do a power off as shutdown does not work, Reboot works

Distance 34:
 starts but why is it needed on a PC?

Etoys 116:
 Error:cannot find gconf path /desktop/sugar/user

Squeek:
 cannot find image file: squeek, did you rnn 'inisqueek -m'?

FotoToon:
 only partially starts
 ?Did not receive a reply........

Pippy 52:
 could not import physics

Ruler 31;
 fails to start
 '...gtk_IS_ASSISTANT (container) failed

Physics 11:
 runs fine but will not stop
 Power off req

Portfolio 44:
 Start screen but does not see starred journal items
 ?Did not receive a reply........

Clock 15:
 clock face disappears at start

Get Books 14:
 f3 icon does not color after usee
Comment 6 satellitgo 2013-11-07 08:16:36 EST
after yum update:
Clock works
Comment 7 Fedora Update System 2013-11-08 23:24:59 EST
sugar-portfolio-44-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Fedora Update System 2013-11-08 23:25:58 EST
sugar-record-99-3.fc20, sugar-memorize-45-3.fc20, sugar-clock-15-3.fc20, sugar-speak-47-3.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.