Bug 102056 - devlabel must be run twice to add symlink for USB hard drive
devlabel must be run twice to add symlink for USB hard drive
Status: CLOSED DUPLICATE of bug 144537
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: devlabel (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-08-09 21:49 EDT by Chris Runge
Modified: 2014-03-16 22:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:58:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Runge 2003-08-09 21:49:11 EDT
Description of problem:

I have a USB hard drive connected to a Cardbus USB 2 card. When I try to use
devlabel to add a symlink for the device in question (/dev/sda1), it is
necessary to run the command twice. The first time it complains that it can't
see the device in /proc/partitions. e.g.,

# /sbin/devlabel add -s /dev/firelite -d /dev/sda1
 
Failure.
The device you are trying to add to devlabel does not show up in
/proc/partitions.

# /sbin/devlabel add -s /dev/firelite -d /dev/sda1
SYMLINK: /dev/firelite -> /dev/sda1
Added /dev/firelite to /etc/sysconfig/devlabel


Version-Release number of selected component (if applicable):

devlabel-0.41.01-1

How reproducible:

100% reproducible if USB hard drive has not yet been mounted
Comment 1 Bill Nottingham 2003-08-10 23:01:02 EDT
Odd, devlabel should be getting run by hotplug anyway.
Comment 2 Bill Nottingham 2005-01-21 18:14:35 EST

*** This bug has been marked as a duplicate of 144537 ***
Comment 3 Red Hat Bugzilla 2006-02-21 13:58:04 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.