Bug 1020564 - cloud-init requires documentation
cloud-init requires documentation
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: doc-Installation_Guide (Show other bugs)
6.4
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Clayton Spicer
ecs-bugs
: Documentation
Depends On:
Blocks: 1269194
  Show dependency treegraph
 
Reported: 2013-10-17 19:48 EDT by Summer Long
Modified: 2017-04-02 20:25 EDT (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-03-31 07:41:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Summer Long 2013-10-17 19:48:37 EDT
Description of problem:
cloud-init was introduced in 6.4
http://rhn.redhat.com/errata/RHEA-2013-0535.html

Currently, there is no RHEL cloud-init documentation (neither description nor configuration). Rudi thought that the likely place would be the Deployment Guide.
Comment 2 Tim Hildred 2013-10-22 03:44:45 EDT
This is also important to RHEV, here is a bug for cross-referencing purposes.
https://bugzilla.redhat.com/show_bug.cgi?id=977201
Comment 9 Summer Long 2015-07-08 21:06:02 EDT
I initially raised this because, although cloud-init is used in OpenStack images (and elsewhere), it is included in RHEL packaging. Should at least have a basic intro somewhere?
Comment 12 Yoana Ruseva 2016-04-22 10:38:33 EDT
Hello Giuseppe, 

I am working on a related bug for Atomic Host: BZ#1270656. This is a request to update the doc with the new features for Atomic. As I understand it, cloud-init is something like a Kickstart file for cloud images and does not apply only to Atomic, so more generic docs would be useful. Could you explain what cloud-init can be used for, so we can decide under which product it should be documented? Related to this, if it is only for cloud-images, why is it available in RHEL as an RPM? What is the use case there?

Thanks!
Comment 14 Yoana Ruseva 2016-04-27 08:17:55 EDT
Thanks Giuseppe, just to clarify, is there any benefit particularly for RHEL users? If there isn't anything significant, cloud-init will stay in the Atomic docs only.
Comment 15 Giuseppe Scrivano 2016-04-27 08:33:48 EDT
cloud-init can still be used by RHEL users, but I think it makes more sense for  Atomic users
Comment 17 Summer Long 2016-04-27 18:37:00 EDT
My question would be, who delivers cloud-init? Other products use it as well, like OpenStack. So, whichever channel delivers it (RHEL?), the user will go to that product for information.
Comment 22 Summer Long 2016-08-03 20:18:18 EDT
I'm no longer in docs, so referring this to Andrew, who can review it in light of other OpenStack docs. Andrew can also ensure that the OpenStack docs now correctly refer to the updated RHEL docs. Thanks for your work, Maxim. Nice to have it done. :)

Andrew?
Comment 23 Andrew Dahms 2016-08-21 20:52:59 EDT
Hi Summer,

Thank you for the needinfo request.

Maxim -

The list of resources looks good, but I wonder whether it would help reduce the maintenance cost if we were just to list the titles for each product and link to the documentation splash page for each product rather than the individual guides for specific versions.

Whatever works easiest. :)

Kind regards,

Andrew
Comment 27 Giuseppe Scrivano 2016-09-12 05:28:11 EDT
I've looked at the added stuff and it looks good to me

Note You need to log in before you can comment on or make changes to this bug.