Bug 1020569 - unknown install shows up as entire disks instead of mount points of selected disks
unknown install shows up as entire disks instead of mount points of selected ...
Status: CLOSED DUPLICATE of bug 1022418
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: anaconda (Show other bugs)
Unspecified Unspecified
unspecified Severity high
: rc
: ---
Assigned To: Brian Lane
Release Test Team
Depends On: 1019541
  Show dependency treegraph
Reported: 2013-10-17 20:43 EDT by Brian Lane
Modified: 2013-12-16 14:00 EST (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1019541
Last Closed: 2013-12-16 14:00:31 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Brian Lane 2013-10-17 20:43:42 EDT
+++ This bug was initially created as a clone of Bug #1019541 +++

I started an install with F20 TC4 x86_64 netinstall (anaconda-20.25-1) burned to a usb disk with litd on a system with several disks.

I selected 2 of 4 disks not including the usb stick (sda, sdc) for installation, selected encryption and went into custom partitioning.

When the custom partitioning screen shows up, instead of seeing the mount points on sda and sdc, I see all of the disks in my system despite the bottom of the screen saying "2 storage devices selected" (customPartitioningDisks.png).

Another odd thing is that when I look at the selected disks dialog, it's empty (selectedDisks.png)

--- Additional comment from Tim Flink on 2013-10-16 00:10:12 EDT ---

I tried custom partitioning on my other machine with multiple disks (2x 36G, 1x 1TB, no encryption and a mix of LVM, standard partitions) and everything shows up fine, so it's something about the difference between those systems 

I also tried removing my raid card on the problematic system but ended up with the same results.

--- Additional comment from David Lehman on 2013-10-16 11:07:34 EDT ---

There are a few things going wrong here:

 1. parted is rejecting the disklabels on sda, sdb, and sdc
 2. something is failing to import __init__ (see anaconda.log@20:14:20,371)
 3. part of commit 1bcfb368 changed things so that now we treat the absence
    of a suitable stage1 bootloader device as a fatal error even if the
    user is headed into the custom spoke

--- Additional comment from Tim Flink on 2013-10-16 11:41:44 EDT ---

(In reply to David Lehman from comment #8)
> There are a few things going wrong here:
>  1. parted is rejecting the disklabels on sda, sdb, and sdc

I've had problems with corrupt backup gpt tables on this box before and it turns out that it's happened again - all 3 disks had corrupt backup GPT tables.

I rebuilt the backup tables from the primary tables, restarted anaconda and everything appears to be showing up correctly now. I was able to create a layout using the existing partitions and have started the actual installation.

I suspect that this no longer qualifies as a beta blocker unless I'm misunderstanding 2) or 3) from c#8

ite not being selected will still be displayed correctly, and nothing about them will be changed by default (it would still take explicit user action to destroy any of their contents).

--- Additional comment from Jan Sedlák on 2013-10-17 08:37:29 EDT ---

I have installed F20 on two disks using msdos partition table (BIOS). I put root, swap and boot on first disk and home on second disk. Then I booted F20 Beta TC4 netinst using UEFI and both disks showed up correctly. It showed correct partition names and sizes

--- Additional comment from Brian C. Lane on 2013-10-17 14:21:53 EDT ---

I can reproduce this on UEFI. wipe the 2 disks in the machine, go to custom, they show up as 'unknown'. On BIOS everything seems to be working fine.
Comment 2 Tim Flink 2013-10-17 21:01:05 EDT
removing fedora blocker related whiteboard items and trackers
Comment 3 Brian Lane 2013-10-17 21:12:54 EDT
This is a side-effect of the fix for bug 1013474
Comment 4 Brian Lane 2013-10-18 12:43:23 EDT
A patch for this has been pushed for Fedora. commit 1531e41a3ce208ce6b7104f8eaac1a4951b955f1
Comment 5 Brian Lane 2013-12-16 14:00:31 EST
Already fixed.

*** This bug has been marked as a duplicate of bug 1022418 ***

Note You need to log in before you can comment on or make changes to this bug.