Bug 1020570 - UTF-8 -- "Revision History" <title> garbled in translated revision histories in non-Latin scripts
UTF-8 -- "Revision History" <title> garbled in translated revision histories ...
Status: CLOSED CURRENTRELEASE
Product: Publican
Classification: Community
Component: publican (Show other bugs)
future
Unspecified Unspecified
unspecified Severity unspecified
: 3.2
: ---
Assigned To: Jeff Fearn
tools-bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-17 20:48 EDT by Ruediger Landmann
Modified: 2013-12-18 21:46 EST (History)
2 users (show)

See Also:
Fixed In Version: 4.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-18 21:46:41 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ruediger Landmann 2013-10-17 20:48:48 EDT
Description of problem:
the Revision_History.xml file created by Publican update_po contains a garbled <title> in languages with a non-Latin script.

Version-Release number of selected component (if applicable):
observed in publican-3.9.9-0.fc19.t11.noarch and publican-3.9.9-0.el6eng.t7.noarch

How reproducible:
100%

Steps to Reproduce:
1. Choose a book without an ru-RU translation (or delete the ru-RU/Revision_History.xml file from a book)
2. Run update_pot and update_po --langs ru-RU
3. Examine ru-RU/Revision_History.xml

Actual results:
Gibberish: <title>ÐÑÑоÑÐ¸Ñ Ð¿ÐµÑеизданиÑ</title>

Expected results:
Cyrillic text: <title>История изменений</title>

Additional info:
Comment 2 Jeff Fearn 2013-10-17 22:21:27 EDT
Please supply a link to something I can test with.
Comment 3 HSS Product Manager 2013-10-17 22:27:31 EDT
HSS-QE has reviewed and declined this request. QE for this bug will be handled by IED.
Comment 4 Ruediger Landmann 2013-10-18 00:13:01 EDT
(In reply to Jeff Fearn from comment #2)
> Please supply a link to something I can test with.

You can test this one with the PUG, since it doesn't have any translations in languages with non-Latin scripts (so the <translation>/Revision_History.xml file will be newly generated when you run update_po). 

I'll also find a book with a suitable translation so you can test what happens when the action touches a language with a translated Revision_History.xml
Comment 6 Jeff Fearn 2013-10-18 01:19:38 EDT
To ssh://git.fedorahosted.org/git/publican.git
   a7c63d1..181eacd  devel -> devel
Comment 7 Ruediger Landmann 2013-10-18 20:14:11 EDT
fixed in publican-3.9.9-0.fc19.t14.noarch

Note You need to log in before you can comment on or make changes to this bug.