Bug 1020581 - scsi-block should only work when targeting a disk or a CD-ROM LUN
scsi-block should only work when targeting a disk or a CD-ROM LUN
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
7.0
x86_64 Linux
medium Severity medium
: rc
: ---
Assigned To: Fam Zheng
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-17 22:51 EDT by FuXiangChun
Modified: 2014-04-04 02:49 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1025342 (view as bug list)
Environment:
Last Closed: 2014-04-04 02:49:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 3 Paolo Bonzini 2013-10-31 10:07:10 EDT
> 1.If Boot guest with lun 1
> -drive file=iscsi://10.66.8.151:3260/libscisi-test/1
> result: qemu quit and print this message
> 
> (qemu) qemu-kvm: -device scsi-block,drive=drive-disk,bus=scsi1.0,id=iscsi-disk: scsi-block: scsi generic interface too old

I cannot reproduce this.  The bug is because lun 0 is not a disk in your setup.  I changed the subject accordingly.
Comment 8 Fam Zheng 2014-04-04 02:49:44 EDT
Double checked that the crash is not reproducible with qemu-kvm-1.5.3-60.el7. Closing this one.

Note You need to log in before you can comment on or make changes to this bug.