Bug 1020611 - [RFE] give some friendly messages when boot qemu-kvm with "-vnc :-5900"
[RFE] give some friendly messages when boot qemu-kvm with "-vnc :-5900"
Status: CLOSED DUPLICATE of bug 733600
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
7.0
x86_64 Linux
low Severity low
: rc
: ---
Assigned To: Virtualization Maintenance
Virtualization Bugs
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-18 00:52 EDT by Jun Li
Modified: 2013-10-22 12:29 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-22 12:29:21 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jun Li 2013-10-18 00:52:50 EDT
Description of problem:
When boot qemu-kvm with "-vnc :-5900", the listening port will not be 0 port of host. The listening port will be changed by host. So qemu-kvm should give some friendly messages.  

Version-Release number of selected component (if applicable):
qemu-kvm-rhev-1.5.3-9.el7.x86_64
3.10.0-34.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1.Boot qemu-kvm with "-vnc :-5900".
# /usr/libexec/qemu-kvm -vnc :-5900 -monitor stdio
2.Check the listening port.
(qemu) info vnc


Actual results:
(qemu) info vnc 
Server:
     address: 0.0.0.0:47569
        auth: none
Client: none

Every time this port is different.

Expected results:
When boot qemu-kvm with "-vnc :-5900", qemu-kvm can not give some warning message or forbids using this port.

Additional info:
I also test "-spice port=0", it will give a error message.
# /usr/libexec/qemu-kvm -vnc :-5900 -spice port=0 -monitor stdio
qemu-kvm: neither port nor tls-port specified for spice
Comment 3 Hai Huang 2013-10-22 12:29:21 EDT

*** This bug has been marked as a duplicate of bug 733600 ***

Note You need to log in before you can comment on or make changes to this bug.