Bug 102063 - Minor fixes for devel package deps.
Minor fixes for devel package deps.
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: librsvg2 (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Alexander Larsson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-08-10 05:27 EDT by Dams
Modified: 2007-04-18 12:56 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-09-04 05:16:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dams 2003-08-10 05:27:10 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.7 (X11; Linux i686; U;) Gecko/20030131

Description of problem:
This what is currently in spec file : 
Requires:       %{name} = %{version}
It should be :
Requires:       %{name} = %{epoch}:%{version}-%{release}

release and epoch are important because static lib (.a) must match the dynamic
version of the lib (.so).

Epoch might be specified in theese requires : 
Requires:       gtk2-devel >= %{gtk2_version}
Requires:       libxml2-devel >= %{libxml2_version}
Requires:       freetype-devel >= %{freetype_version}
Requires:       libart_lgpl-devel >= %{libart_version}

And 'Requires: libgsf-devel' is missing : 
[anvil@gruyere ~/fedora/spec]# pkg-config librsvg-2.0 --libs
Package libgsf-1 was not found in the pkg-config search path.
Perhaps you should add the directory containing `libgsf-1.pc'
to the PKG_CONFIG_PATH environment variable
Package 'libgsf-1', required by 'librsvg', not found
[anvil@gruyere ~/fedora/spec]# apt-get install libgsf-devel
[snip]
[anvil@gruyere ~/fedora/spec]# pkg-config librsvg-2.0 --libs
-Wl,--export-dynamic -lrsvg-2 -lgdk_pixbuf-2.0 -lart_lgpl_2 -lpangoft2-1.0
-lgsf-1 -lpango-1.0 -lgmodule-2.0 -ldl -lgobject-2.0 -lxml2 -lz -lm -lglib-2.0


Version-Release number of selected component (if applicable):
librsvg2(0:2.2.3-5)

How reproducible:
Always

Steps to Reproduce:
None.

Additional info:
Comment 1 Alexander Larsson 2003-09-04 05:16:30 EDT
Fixed in 2.3.1-2

Note You need to log in before you can comment on or make changes to this bug.