Bug 1020691 - RHS-C: After importing a cluster, brick status shows as DOWN even though the volume is UP
RHS-C: After importing a cluster, brick status shows as DOWN even though the ...
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: rhsc (Show other bugs)
2.1
Unspecified Unspecified
medium Severity high
: ---
: RHGS 2.1.2
Assigned To: Bala.FA
Prasanth
: ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-18 03:52 EDT by Prasanth
Modified: 2015-05-13 12:32 EDT (History)
10 users (show)

See Also:
Fixed In Version: rhsc-2.1.2-0.25.master.el6_5
Doc Type: Bug Fix
Doc Text:
Previously, brick status was displayed as Down even though the volume was UP during Import Cluster. Now, with this update, the brick status is displayed correctly.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-25 02:55:18 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot of bricks tatus (101.10 KB, image/png)
2013-10-18 03:52 EDT, Prasanth
no flags Details

  None (edit)
Description Prasanth 2013-10-18 03:52:00 EDT
Created attachment 813642 [details]
screenshot of bricks tatus

Description of problem:

After importing a cluster, brick status shows as DOWN for some time, even though the volume is UP.

[root@vm11 home]# gluster volume status
Status of volume: vol4
Gluster process                                         Port    Online  Pid
------------------------------------------------------------------------------
Brick vm11.lab.eng.blr.redhat.com:/home/2               49153   Y       19158
Brick vm12.lab.eng.blr.redhat.com:/home/2               49152   Y       26064
NFS Server on localhost                                 2049    Y       19172
NFS Server on vm12.lab.eng.blr.redhat.com               2049    Y       26078
 
Task Status of Volume vol4
------------------------------------------------------------------------------


Version-Release number of selected component (if applicable): 

[root@vm07 /]# rpm -qa |grep rhsc
rhsc-restapi-2.1.2-0.0.scratch.beta1.el6_4.noarch
rhsc-lib-2.1.2-0.0.scratch.beta1.el6_4.noarch
rhsc-cli-2.1.0.0-0.bb3a.el6rhs.noarch
rhsc-webadmin-portal-2.1.2-0.0.scratch.beta1.el6_4.noarch
rhsc-sdk-2.1.0.0-0.bb3a.el6rhs.noarch
rhsc-branding-rhs-3.3.0-1.0.master.201309200500.fc18.noarch
rhsc-backend-2.1.2-0.0.scratch.beta1.el6_4.noarch
rhsc-tools-2.1.2-0.0.scratch.beta1.el6_4.noarch
rhsc-dbscripts-2.1.2-0.0.scratch.beta1.el6_4.noarch
rhsc-setup-2.1.2-0.0.scratch.beta1.el6_4.noarch
rhsc-2.1.2-0.0.scratch.beta1.el6_4.noarch
rhsc-log-collector-2.1-0.1.el6rhs.noarch


[root@vm12 /]#  rpm -qa |grep vdsm
vdsm-4.13.0-17.gitdbbbacd.el6_4.x86_64
vdsm-python-4.13.0-17.gitdbbbacd.el6_4.x86_64
vdsm-python-cpopen-4.13.0-17.gitdbbbacd.el6_4.x86_64
vdsm-xmlrpc-4.13.0-17.gitdbbbacd.el6_4.noarch
vdsm-cli-4.13.0-17.gitdbbbacd.el6_4.noarch
vdsm-gluster-4.13.0-17.gitdbbbacd.el6_4.noarch
vdsm-reg-4.13.0-17.gitdbbbacd.el6_4.noarch


How reproducible: Always


Steps to Reproduce:
1. Create a cluster having 2 servers from Gluster CLI
2. Create a volume and start it from CLI
3. Now, import the created cluster using UI
Confirm the status of bricks using "gluster volume status"
4. Once all the servers are imported successfully, check the volume status and brick status under "Volumes" tab and "Bricks" sub-tab

Actual results: As soon as the servers and volumes are imported, the volume status immediately shows as UP. However, the status of the bricks will still be displayed as down (Red down arrow) for 5 min or until the next sync job runs, whichever is earlier. This will prevent any additional brick related operation during this time period.


Expected results: After the import cluster is successful, both the volume status and brick status in the UI should reflect the actual status immediately. This can be achieved by getting the "gluster volume status" from the server immediately after the import.


Additional info: Screenshot attached. 

sosreports of engine and 2 nodes will be uploaded soon.
Comment 2 Prasanth 2013-10-18 05:29:49 EDT
sosreports of engine and hosts can be downloaded from: http://rhsqe-repo.lab.eng.blr.redhat.com/sosreports/rhsc/1020691
Comment 3 Dusmant 2013-10-24 03:32:05 EDT
Bala,
    See if this is a pure UI issue or on the vdsm or engine side.

-Dusmant
Comment 4 Shruti Sampat 2013-11-07 06:40:49 EST
With the recent change that updates the volume status according to brick status, the volume status will be shown with a yellow arrow pointing upwards and an exclamation mark beside the arrow, if all the bricks are down.

So, as soon as the import is done, if all bricks are shown as down, the volume status will be shown as explained above, which is misleading, and does not look good.

This needs to be fixed; the brick status should be shown as up, if the volume is up, when import is done.
Comment 5 Bala.FA 2013-11-08 06:16:08 EST
upstream patch is under review at http://gerrit.ovirt.org/21067
Comment 6 Bala.FA 2013-11-21 06:31:57 EST
Downstream patch is at https://code.engineering.redhat.com/gerrit/16122
Comment 7 Prasanth 2013-12-03 06:24:46 EST
Verified as fixed in rhsc-2.1.2-0.25.master.el6_5
Comment 8 Shalaka 2014-01-09 03:56:08 EST
Please review the edited DocText and signoff.
Comment 9 Bala.FA 2014-01-09 04:04:03 EST
i feel the text could be like "Now, with this update, the brick status is displayed same as volume status initially"
Comment 11 errata-xmlrpc 2014-02-25 02:55:18 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2014-0208.html

Note You need to log in before you can comment on or make changes to this bug.