Bug 10207 - Several (minor) bugs in plan and plan-
Several (minor) bugs in plan and plan-
Status: CLOSED RAWHIDE
Product: Red Hat Powertools
Classification: Retired
Component: plan (Show other bugs)
6.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Powers
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-03-16 10:15 EST by Torsten Schuetze
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-05-17 19:00:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Torsten Schuetze 2000-03-16 10:15:57 EST
- plan-1.8.2-1 and plan-server-1.8.2-1 both contain /usr/sbin/netplan
  Only plan-server should have netplan, otherwise we have conflicts

- startup of netplan in /etc/rc.d/init.d/netplan doesn't work (netplan is
not in /usr/lib/netplan)

- If the plan package is installed, pland should be started via
.Xclients-defaults:

test -x /usr/sbin/pland && /usr/sbin/pland -k &&

- There should be an empty directory .plan.dir and empty files
.plan.dir/dayplan and .plan.dir/dayplan.priv in /etc/skel

- If I remember correctly the holiday-file should be copied to
$HOME/.plan.dir/holiday not $HOME/.holiday (It would be fine if not only
american holidays are installed, but this is difficult to handle
automatically)

- After some time I get the message (from pland)
plan: X server fails to send timer events, switching to synchronous file
writing. Time displays will be wrong.

plan used to work perfectly with DLD 6.01.

That's all.
Comment 1 Tim Powers 2000-04-17 09:50:59 EDT
I'll take a look at the DLD package to see what the differences were. Thanks for
the heads up.

Tim
Comment 2 Tim Powers 2000-05-17 19:00:59 EDT
OK, looks like I fixed all the problems you mentioned minus messing with users
.Xclients-default file. I am not comfortable with doing that since it can vary
quite a bit from user to user.

The package will show up in rawhide whenever that gets updated.

Here's the changelog from the package I just built FYI:

* Wed May 17 2000 Tim Powers <timp@redhat.com>
- fixed problems reported by <torsten.schuetze@mchp.siemens.de> in bug #10207
- updated to 1.8.3
- major cleanups in the spec
- use applnk instead of wmconfig
- fixed the netplan init so it actually works now
- fixed so that it builds with XFree86 4.0

You will want to rebuild the source RPM for your machine though.

Tim

Note You need to log in before you can comment on or make changes to this bug.