Bug 1020742 - Fail to connect to INT with existing accounts
Fail to connect to INT with existing accounts
Status: CLOSED CURRENTRELEASE
Product: OpenShift Online
Classification: Red Hat
Component: Pod (Show other bugs)
2.x
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Abhishek Gupta
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-18 04:41 EDT by Qiushui Zhang
Modified: 2015-05-14 20:22 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-29 19:49:01 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Qiushui Zhang 2013-10-18 04:41:16 EDT
Description of problem:
Try to connect to INT with existing account. It will show errors like the following:
[walter@dhcp-10-238 tmp]$ rhc setup --server int.openshift.redhat.com -l qiuzhang+migrate@redhat.com -p $MYPASSWORD
OpenShift Client Tools (RHC) Setup Wizard

This wizard will help you upload your SSH keys, set your application namespace, and check that other programs like Git are properly installed.

Using qiuzhang+migrate@redhat.com to login to int.openshift.redhat.com
Unable to complete the requested operation due to: The operation: #<Moped::Protocol::Query
  @length=138
  @request_id=237
  @response_to=0
  @op_code=2004
  @flags=[]
  @full_collection_name="openshift_broker.cloud_users"
  @skip=0
  @limit=-1
  @selector={"$query"=>{"login"=>"qiuzhang+migrate@redhat.com"}, "$orderby"=>{:_id=>1}}
  @fields=nil>
failed with error 16550: "not authorized for query on openshift_broker.cloud_users"

See https://github.com/mongodb/mongo/blob/master/docs/errors.md
for details about this error..
Reference ID: 4689557591c8fc04f4e4a65b4d8fb429


Version-Release number of selected component (if applicable):
INT(2.0.34)

How reproducible:
always

Steps to Reproduce:
1. Try to connect to INT with existing account
2.
3.

Actual results:
Errors pop up:
This wizard will help you upload your SSH keys, set your application namespace, and check that other programs like Git are properly installed.

Using qiuzhang+migrate@redhat.com to login to int.openshift.redhat.com
Unable to complete the requested operation due to: The operation: #<Moped::Protocol::Query
  @length=138
  @request_id=237
  @response_to=0
  @op_code=2004
  @flags=[]
  @full_collection_name="openshift_broker.cloud_users"
  @skip=0
  @limit=-1
  @selector={"$query"=>{"login"=>"qiuzhang+migrate@redhat.com"}, "$orderby"=>{:_id=>1}}
  @fields=nil>
failed with error 16550: "not authorized for query on openshift_broker.cloud_users"

See https://github.com/mongodb/mongo/blob/master/docs/errors.md
for details about this error..
Reference ID: 4689557591c8fc04f4e4a65b4d8fb429


Expected results:
Connect to INT successfully.

Additional info:
Affected accounts:
qiuzhang+migrate@redhat.com
wsun+migrate@redhat.com
chunchen+migrate@redhat.com
lxia@redhat.com
Comment 1 Wesley Hearn 2013-10-18 09:36:27 EDT
I am able to reproduce this with my account using the command line tools, I do not have it happen with the web console.
Comment 2 Xiaoli Tian 2013-10-18 09:44:41 EDT
(In reply to Wesley Hearn from comment #1)
> I am able to reproduce this with my account using the command line tools, I
> do not have it happen with the web console.

I guess you will meet error like "We appear have technical difficulties"   if you are trying to create app from web console.

Note You need to log in before you can comment on or make changes to this bug.