Bug 1020779 - [RHSC] - Skipped file count is getting displayed as failed file count in rebalance status dialog.
[RHSC] - Skipped file count is getting displayed as failed file count in reba...
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: rhsc (Show other bugs)
2.1
Unspecified Unspecified
high Severity high
: ---
: RHGS 2.1.2
Assigned To: Shubhendu Tripathi
RamaKasturi
: ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-18 05:26 EDT by RamaKasturi
Modified: 2015-05-13 12:32 EDT (History)
7 users (show)

See Also:
Fixed In Version: cb6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-25 02:55:27 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attaching glusterfs log (4.28 MB, text/x-log)
2013-10-21 06:10 EDT, RamaKasturi
no flags Details
Attaching vdsm log (2.54 MB, text/x-log)
2013-10-21 06:11 EDT, RamaKasturi
no flags Details
Attaching screenshot for the same. (221.63 KB, image/png)
2013-10-31 05:23 EDT, RamaKasturi
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 20356 None None None Never

  None (edit)
Description RamaKasturi 2013-10-18 05:26:31 EDT
Description of problem:
Skipped file count is getting displayed as failed file count in rebalance status dialog.

Version-Release number of selected component (if applicable):
rhsc-2.1.2-0.0.scratch.beta1.el6_4.noarch

How reproducible:
Always.

Steps to Reproduce:
1. create a distribute and distribute replicate volume.
2. start the volumes, mount it and create some data in the volumes. Rename some of the files in the mount point for the rebalance to happen.
3. Start rebalance on the volumes.
4. once rebalance is started click on the status button in the drop down menu.
5. go to any of the node and run the command "gluster vol rebalance <volName> status".



Actual results:
failed file count displays the skipped file count.

Expected results:
Verify that skipped and failed file count comes as it is in the CLI output.

Additional info:
Comment 1 RamaKasturi 2013-10-18 05:37:56 EDT
Logs are located in the following location http://rhsqe-repo.lab.eng.blr.redhat.com/sosreports/rhsc/1020779/
Comment 3 RamaKasturi 2013-10-21 03:03:00 EDT
output of "vdsClient -s 0 glusterVolumeRebalanceStatus volumeName=vol_dis1"

{'hosts': [{'filesFailed': '0',
            'filesMoved': '0',
            'filesScanned': '60',
            'filesSkipped': '4',
            'id': 'b3618d16-4c0e-49f3-8b55-19d69d271d4e',
            'name': 'localhost',
            'runtime': 1.0,
            'status': 'COMPLETED',
            'totalSizeMoved': '0'},
           {'filesFailed': '0',
            'filesMoved': '0',
            'filesScanned': '19',
            'filesSkipped': '0',
            'id': '757b310a-000a-4c39-9412-5e87d1ed56e4',
            'name': '10.70.37.166',
            'runtime': 16.0,
            'status': 'IN_PROGRESS',
            'totalSizeMoved': '0'},
           {'filesFailed': '0',
            'filesMoved': '0',
            'filesScanned': '42',
            'filesSkipped': '0',
            'id': 'c772b2ee-f42e-44b3-9e5e-8977cd97473c',
            'name': '10.70.37.61',
            'runtime': 16.0,
            'status': 'IN_PROGRESS',
            'totalSizeMoved': '0'},
           {'filesFailed': '0',
            'filesMoved': '0',
            'filesScanned': '60',
            'filesSkipped': '0',
            'id': '2defacb7-f7e2-43f2-8076-7ce8f197bc7b',
            'name': '10.70.37.69',
            'runtime': 1.0,
            'status': 'COMPLETED',
            'totalSizeMoved': '0'}],
 'status': {'code': 0, 'message': 'Done'},
 'summary': {'filesFailed': '0',
             'filesMoved': '0',
             'filesScanned': '181',
             'filesSkipped': '4',
             'runtime': 16.0,
             'status': 'IN_PROGRESS',
             'totalSizeMoved': '0'}}
Comment 4 RamaKasturi 2013-10-21 06:10:38 EDT
Created attachment 814512 [details]
Attaching glusterfs log
Comment 5 RamaKasturi 2013-10-21 06:11:44 EDT
Created attachment 814513 [details]
Attaching vdsm log
Comment 6 RamaKasturi 2013-10-31 05:22:28 EDT
verified and works fine in the build CB6. (rhsc-2.1.2-0.22.master.el6_4.noarch)

In this build Files skipped does not get displayed as Files failed.

Files skipped gets displayed properly.
Comment 7 RamaKasturi 2013-10-31 05:23:00 EDT
Created attachment 817769 [details]
Attaching screenshot for the same.
Comment 9 errata-xmlrpc 2014-02-25 02:55:27 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2014-0208.html

Note You need to log in before you can comment on or make changes to this bug.