Bug 10208 - tiff file printing broken.
tiff file printing broken.
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: rhs-printfilters (Show other bugs)
6.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Crutcher Dunnavant
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-03-16 11:04 EST by Harvey Stein
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-08 07:25:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Harvey Stein 2000-03-16 11:04:56 EST
The filter program processes tif files by:

   cat - | tiff-to-pnm.fpi | pnm-to-ps.fpi | ps-to-printer.fpi

But, tiff-to-pnm.fpi only converts the *first* page of a tiff file to a pnm
file, so the above only prints the first page of the fax.  The solution is
to use tiff2ps instead of tifftopnm by addding a tiff-to-ps.fpi to
/usr/lib/rhs/rhs-printfilters which looks like:

#!/bin/sh
#
# takes tiff from stdin, writes postscript to stdout
#

TMPFILE=`mktemp /tmp/printtmp.XXXXXX` || exit 1
cat > $TMPFILE
tiff2ps -a $TMPFILE
rm -f $TMPFILE

exit 0


This also has the advantage of making the print chain one step shorter.
Comment 1 Crutcher Dunnavant 2000-08-08 15:54:28 EDT
added this filter to the libtiff package.
thanks.

Note You need to log in before you can comment on or make changes to this bug.