Bug 1020808 - Environment selection box and '+ Additional info' link disappears from system's details page
Environment selection box and '+ Additional info' link disappears from syst...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI (Show other bugs)
6.0.2
Unspecified Unspecified
high Severity medium (vote)
: Unspecified
: --
Assigned To: Walden Raines
Sachin Ghai
http://projects.theforeman.org/issues...
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-18 06:20 EDT by Sachin Ghai
Modified: 2016-04-22 12:13 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-07-02 10:07:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
missing env selection box (69.73 KB, image/png)
2013-10-18 06:20 EDT, Sachin Ghai
no flags Details
missing "+Addition Info" link (61.99 KB, image/png)
2013-10-18 06:21 EDT, Sachin Ghai
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 6174 None None None 2016-04-22 12:13 EDT

  None (edit)
Description Sachin Ghai 2013-10-18 06:20:58 EDT
Created attachment 813708 [details]
missing env selection box

Description of problem:
Register a system via rhsm and use published CV name while passing the env name.

for ex:

subscription-manager register --username admin --password admin --org org-name
--env env-name/cv-pub-name --force 

System should be registered successfully. Now when you navigate the system -->All -->system details page, you will see the "Environment Selection box" and "+ Additional information" link.

But when you navigate to some other tab like 'packages' or events and come back to details tab, the environment selection box and "+ Additional info" link disappears

Version-Release number of selected component (if applicable):
snap6 compose2 (MDP2)
katello-1.4.6-40.el6sat.noarch


How reproducible:
always

Steps to Reproduce:
1. Create a product/repo and sync it
2. create a cv and select the product and publish it
3. Promote the cv to next env 
4. Register the system via rhsm and pass published name along ith env name ( as suggested above)
5. Go to Systems --All -> select registered systems --> details
6. Navigate to 'Package' or 'Events' tabs
7. Again select 'details' tab

Actual results:
Environment selection box and  '+ Additional info'  link disappears from system's details page

Expected results:
should be there

Additional info:
Comment 1 Sachin Ghai 2013-10-18 06:21:45 EDT
Created attachment 813709 [details]
missing "+Addition Info" link
Comment 3 Walden Raines 2014-06-11 16:11:50 EDT
(In reply to Sachin Ghai from comment #0)
> Steps to Reproduce:
> 1. Create a product/repo and sync it
> 2. create a cv and select the product and publish it
> 3. Promote the cv to next env 
> 4. Register the system via rhsm and pass published name along ith env name (
> as suggested above)
> 5. Go to Systems --All -> select registered systems --> details
> 6. Navigate to 'Package' or 'Events' tabs
> 7. Again select 'details' tab

Was able to reproduce, steps 1-3 are not necessary.
Comment 4 Walden Raines 2014-06-11 16:23:04 EDT
Created redmine issue http://projects.theforeman.org/issues/6174 from this bug
Comment 5 Walden Raines 2014-06-11 16:28:12 EDT
PR: https://github.com/Katello/katello/pull/4253
Comment 6 Walden Raines 2014-06-11 17:23:47 EDT
commit 384fc2a16822d5dc0af06df050ee7b62c0461d8a
Merge: 341c7e0 6cf41a9
Author: Walden Raines <walden@redhat.com>
Date:   Wed Jun 11 17:23:07 2014 -0400

    Merge pull request #4253 from waldenraines/6174
    
    Fixes #6174/BZ 1020808 - ensure host advanced info link is displayed.

commit 6cf41a9f2cd16065027a96d12508def0fc27b8e5
Author: Walden Raines <walden@redhat.com>
Date:   Wed Jun 11 16:23:17 2014 -0400

    Fixes #6174/BZ 1020808 - ensure host advanced info link is displayed.
    
    The problem was that the event 'contentHost.loaded' only fired upon
    the first visit to this page.  Using the $promise instead results
    in the advanced info link being displayed each time.
Comment 9 Sachin Ghai 2014-06-13 02:27:27 EDT
Verified with snap9 compose2. (Satellite-6.0.3-RHEL-6-20140612.1)

I can see Environment selection box and  '+ Additional info'  link after navigating to some other page and then come back to content-host details page.
Comment 10 Bryan Kearney 2014-07-02 10:07:32 EDT
This was delivered with 6.0.3, which is the Satellite 6 Beta.

Note You need to log in before you can comment on or make changes to this bug.