Bug 1020828 - Unify buttons style - delete, remove, abort, undeploy
Unify buttons style - delete, remove, abort, undeploy
Status: CLOSED NOTABUG
Product: JBoss BRMS Platform 6
Classification: JBoss
Component: Business Central (Show other bugs)
6.0.0
Unspecified Unspecified
low Severity low
: ---
: ---
Assigned To: manstis
Zuzana Krejčová
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-18 06:58 EDT by Zuzana Krejčová
Modified: 2016-07-31 21:09 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-07 08:13:42 EST
Type: Enhancement
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
buttons screenshots (136.41 KB, application/zip)
2013-10-18 06:58 EDT, Zuzana Krejčová
no flags Details

  None (edit)
Description Zuzana Krejčová 2013-10-18 06:58:30 EDT
Created attachment 813716 [details]
buttons screenshots

Description of problem:
For various delete, remove, abort and undeploy buttons, there are currently 7 styles. It would benefit the look & feel of the product, if they were somehow unified. It doesn't look like a product made by one company right now.

I'm adding Catherine to CC, as she knows more about these things.

There is the inverted minus sign for the guided editors, the cross in Data modeler, the empty set sign for undeploy and abort instance, red button with text for repositories, organizational units and imports, grey button with text for uploaded jars, kbases section of Project Screen and assets, the trash bin icon for project dependencies and finally another trash icon, with a cross over it, for deleting a process in the Designer. See screenshots.

We could probably keep two types of buttons - one type with text for places where there is enough space (delete asset, repository, org. unit, remove dependency, import..), one type with a simple icon to be used where there isn't enough space (guided editors, Data modeler, ...).
I'd suggest the cross for the icon as the trash was intentionally removed already (at least from Data modeler).

Catherine, could you add your thoughts on this?


Version-Release number of selected component (if applicable):
BPMS 6.0 ER4
Comment 1 Catherine Robson 2013-10-18 08:48:10 EDT
Abort and Delete are definitely two different actions, and undeploy might be a third.  I think we can definitely do a better job of being more consistent with the icons we use for these things, and over time making the button styles more consistent as well when we use a button w/ the icons or words.  

Adding Joe Sniezek to the bug as well.  We'll take a closer look and provide a recommendation on a standard we might want to start following for this.
Comment 2 Jan Hrcek 2015-12-07 08:13:42 EST
A lot of work has been done to unify visual style across various business-central components. Since this bugzilla doesn't mention anything specific to look at, closing as NOTABUG

Note You need to log in before you can comment on or make changes to this bug.