Bug 1020855 - rootfs on thinp not found, startup failure
rootfs on thinp not found, startup failure
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: dracut (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity high
: rc
: ---
Assigned To: dracut-maint
Release Test Team
:
: 1027694 (view as bug list)
Depends On: 1013767
Blocks: 744225
  Show dependency treegraph
 
Reported: 2013-10-18 07:38 EDT by Marian Csontos
Modified: 2014-06-17 23:56 EDT (History)
24 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1013767
Environment:
Last Closed: 2014-06-13 09:13:04 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Dracut mode (121.26 KB, image/jpeg)
2013-11-11 10:25 EST, IBM Bug Proxy
no flags Details
journalctl logs (94.35 KB, image/jpeg)
2013-11-11 10:26 EST, IBM Bug Proxy
no flags Details
anaconda log (17.49 KB, application/octet-stream)
2013-11-11 10:26 EST, IBM Bug Proxy
no flags Details
storage log (208.57 KB, application/octet-stream)
2013-11-11 10:26 EST, IBM Bug Proxy
no flags Details
program log (41.43 KB, application/octet-stream)
2013-11-11 10:27 EST, IBM Bug Proxy
no flags Details

  None (edit)
Description Marian Csontos 2013-10-18 07:38:40 EDT
+++ This bug was initially created as a clone of Bug #1013767 +++

Description of problem: Fedora 20 guided partitioning scheme LVM Thing Provision is selected and system is installed successfully but on reboot, dropped to dracut prompt.

Version-Release number of selected component (if applicable):
F20: dracut-032-1.fc20.x86-64
RHEL7: dracut-033-26.el7.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Fedora 20 desktop ISO, boot and install using LVM Thin Provisioning in guided partitioning.
2. Reboot after successful install

Actual results:
dracut-initqueue[196]: Warning: /dev/fedora_f20s/root does not exist

Expected results:
Startup to a login prompt or desktop.

There are two issues:

- thin executable are not copied to ramdisk
- dracut searching for 

Patches for both problems are atteached to original F20 BZ.
Comment 3 Jan Stodola 2013-11-11 10:18:31 EST
*** Bug 1027694 has been marked as a duplicate of this bug. ***
Comment 4 Jan Stodola 2013-11-11 10:19:55 EST
Reproduced with dracut-033-26.el7.
No longer able to reproduce with dracut-033-40.el7.

Moving to VERIFIED.
Comment 5 IBM Bug Proxy 2013-11-11 10:25:59 EST
Created attachment 822468 [details]
Dracut mode
Comment 6 IBM Bug Proxy 2013-11-11 10:26:13 EST
Created attachment 822469 [details]
journalctl logs
Comment 7 IBM Bug Proxy 2013-11-11 10:26:38 EST
Created attachment 822470 [details]
anaconda log
Comment 8 IBM Bug Proxy 2013-11-11 10:26:55 EST
Created attachment 822471 [details]
storage log
Comment 9 IBM Bug Proxy 2013-11-11 10:27:10 EST
Created attachment 822472 [details]
program log
Comment 10 IBM Bug Proxy 2013-12-09 05:54:46 EST
------- Comment From igangadh@in.ibm.com 2013-12-09 10:40 EDT-------
(In reply to comment #15)
> +++ This bug was initially created as a clone of Bug #1013767 +++
>
> Description of problem: Fedora 20 guided partitioning scheme LVM Thing
> Provision is selected and system is installed successfully but on reboot,
> dropped to dracut prompt.
>
> Version-Release number of selected component (if applicable):
> F20: dracut-032-1.fc20.x86-64
> RHEL7: dracut-033-26.el7.x86_64
>
> How reproducible:
> Always
>
> Steps to Reproduce:
> 1. Fedora 20 desktop ISO, boot and install using LVM Thin Provisioning in
> guided partitioning.
> 2. Reboot after successful install
>
> Actual results:
> dracut-initqueue[196]: Warning: /dev/fedora_f20s/root does not exist
>
> Expected results:
> Startup to a login prompt or desktop.
>
> There are two issues:
>
> - thin executable are not copied to ramdisk
> - dracut searching for
>
> Patches for both problems are atteached to original F20 BZ.
>
> *** Bug 1027694 has been marked as a duplicate of this bug. ***
>
> Reproduced with dracut-033-26.el7.
> No longer able to reproduce with dracut-033-40.el7.
>
> Moving to VERIFIED.

The system goes for kernel panic state when we select the LVM thin provisioning while installing   while setting root password  installation aborts      Hence reopening the ticket  .
Let me know if any logs required
[  108.195881]  [<0000000000227180>] kswapd+0x158/0x46c
[  108.195883]  [<000000000015e69a>] kthread+0xe6/0xec
[  108.195891]  [<00000000005db73e>] kernel_thread_starter+0x6/0xc
[  108.195895]  [<00000000005db738>] kernel_thread_starter+0x0/0xc
[  108.195897] Last Breaking-Event-Address:
[  108.195898]  [<00000000002228fc>] shrink_slab+0xc4/0x440
[  108.195899]
[  108.195900] Kernel panic - not syncing: Fatal exception: panic_on_oops
00: HCPGIR450W CP entered; disabled wait PSW 00020001 80000000 00000000 0010E6F6
Comment 11 Jan Stodola 2013-12-09 07:03:08 EST
It is a different issue, related to kernel. It happens also on x86_64 and it has been reported as bug 1039546.
Comment 12 IBM Bug Proxy 2013-12-10 02:11:39 EST
------- Comment From mgrf@de.ibm.com 2013-12-10 07:09 EDT-------
(In reply to comment #20)
> It is a different issue, related to kernel. It happens also on x86_64 and it
> has been reported as bug 1039546.

Thanks Jan,
with the new bug RH 1039546 ...  reported
I set this one verified on IBM site as per actual test results - feel free to re-open if any issue might re-occur beside the above new reported BZ
Comment 13 Ludek Smid 2014-06-13 09:13:04 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.