Bug 1020857 - One fullscreen display has an offset and cannot cover the physical monitor
One fullscreen display has an offset and cannot cover the physical monitor
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-viewer (Show other bugs)
6.5
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Virt Viewer Maint
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-18 07:44 EDT by CongDong
Modified: 2015-05-11 18:16 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-13 00:27:36 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
virt-viewer and spice log (36.29 KB, text/x-log)
2013-10-18 07:45 EDT, CongDong
no flags Details
Screen shot (2.71 MB, image/png)
2013-10-18 07:47 EDT, CongDong
no flags Details

  None (edit)
Description CongDong 2013-10-18 07:44:44 EDT
Description of problem:
A rhel6.5 guest with two display, when connect it with fullscreen, sometime,one of the display cannot cover the physical monitor, there is a big offset between the display and the monitor.

Version-Release number of selected component (if applicable):
# rpm -qa virt-viewer
virt-viewer-0.5.6-8.el6.x86_64
# rpm -qa | grep spice*
spice-glib-0.20-9.el6.x86_64
spice-vdagent-0.14.0-2.el6.x86_64
spice-gtk-python-0.20-9.el6.x86_64
spice-gtk-0.20-9.el6.x86_64
spice-server-0.12.4-6.el6.x86_64

How reproducible:
50%

Steps to Reproduce:
1. Prepare a rhel6.5 guest with two display, and a host with two physical monitors.
2. # virt-viewer rhel6.5 -f --debug
3.

Actual results:
As the Description

Expected results:
The two displays can cover the physical monitor.

Additional info:
It's not easy to reproduce, but if I reproduce one time, it can always be reproduced then.
Comment 1 CongDong 2013-10-18 07:45:50 EDT
Created attachment 813755 [details]
virt-viewer and spice log
Comment 2 CongDong 2013-10-18 07:47:06 EDT
Created attachment 813756 [details]
Screen shot
Comment 3 tingting zheng 2013-11-21 05:01:42 EST
I can not reproduce this issue on latest version:
Version:
libvirt-0.10.2-29.el6.1.x86_64
virt-viewer-0.5.6-8.el6.x86_64
spice-gtk-python-0.20-11.el6.x86_64
spice-xpi-2.7-24.el6.x86_64
spice-vdagent-0.14.0-2.el6.x86_64
spice-glib-0.20-11.el6.x86_64
spice-gtk-0.20-11.el6.x86_64
spice-server-0.12.4-6.el6.x86_64
Comment 4 Marc-Andre Lureau 2014-03-12 16:45:57 EDT
based on comment #2, congdong, can you still reproduce?

(I don't really understand the screenshot either tbh :) Is it the client window in fullscreen with an offset? That would be a metacity bug in that case)
Comment 5 CongDong 2014-03-12 23:15:59 EDT
I tested with:
spice-glib-0.20-11.el6.x86_64
spice-server-0.12.4-6.el6.x86_64
spice-gtk-python-0.20-11.el6.x86_64
spice-vdagent-0.14.0-2.el6.x86_64
spice-gtk-0.20-11.el6.x86_64
virt-viewer-0.5.6-9.el6_5.x86_64

Cannot reproduce now with the lastest version packages.
Comment 6 Cui Lei 2014-03-13 00:27:36 EDT
According comment3 and comment5, could not reproduce the issue with latest version. so close this bug as CURRENTRELEASE. Thanks for codong's efforts.

Note You need to log in before you can comment on or make changes to this bug.