Bug 1020862 - app will can not be accessible when deployment a wrong ID for python-3.3
app will can not be accessible when deployment a wrong ID for python-3.3
Status: CLOSED DUPLICATE of bug 1020365
Product: OpenShift Online
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
All Unspecified
medium Severity medium
: ---
: ---
Assigned To: Jhon Honce
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-18 08:03 EDT by zhaozhanqi
Modified: 2015-05-14 19:30 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-18 08:35:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description zhaozhanqi 2013-10-18 08:03:44 EDT
Description of problem:
Given a python-3.3 app, change auto-deploy to no, change something and git push. deploy this app with a wrong deployment ID, app will deploy failed, after that this app will can not be accessible. and then use a right ID deploy, still failed.


Version-Release number of selected component (if applicable):
devenv_3912

How reproducible:
always

Steps to Reproduce:
1. create one non-scale app
2. set auto-deploy to no
3. change something and git push
4. deploy this app with a wrong ID
   rhc deploy 3333 -a zqpy33
5. access this app

Actual results:
rhc deploy 695a7849 -a zqpy33 
Deployment of git ref '695a7849' in progress for application zqpy33 ...
An error occurred executing 'gear deploy' (exit code: 1)
Error message: Shell command '
set -xe;
shopt -s dotglob;
if [ "$(find objects -type f 2>/dev/null | wc -l)" -eq "0" ]; then
  exit 0;
fi
git archive --format=tar 695a7849 | (cd /var/lib/openshift/52611377ecfb2d2db4000160/app-deployments/2013-10-18_07-00-25.112/repo && tar --warning=no-timestamp -xf -);
' returned an error. rc=1
stdout: 
stderr: + shopt -s dotglob
++ wc -l
++ find objects -type f
+ '[' 30 -eq 0 ']'
+ git archive --format=tar 695a7849
+ cd /var/lib/openshift/52611377ecfb2d2db4000160/app-deployments/2013-10-18_07-00-25.112/repo
+ tar --warning=no-timestamp -xf -
fatal: Not a valid object name
tar: This does not look like a tar archive
tar: Exiting with failure status due to previous errors

For more details about the problem, try running the command again with the '--trace' option.
Success

step 5
cannot be accessible.

Expected results:
deploy failed. but this app still can access. 

Additional info:
Comment 1 Andy Goldstein 2013-10-18 08:35:33 EDT

*** This bug has been marked as a duplicate of bug 1020365 ***

Note You need to log in before you can comment on or make changes to this bug.