Bug 1020889 - Remove notice about REST-api being a preview
Remove notice about REST-api being a preview
Status: CLOSED CURRENTRELEASE
Product: JBoss Operations Network
Classification: JBoss
Component: REST (Show other bugs)
JON 3.2
Unspecified Unspecified
unspecified Severity high
: ER07
: JON 3.2.0
Assigned To: Heiko W. Rupp
:
Depends On:
Blocks: 1012435
  Show dependency treegraph
 
Reported: 2013-10-18 09:01 EDT by Heiko W. Rupp
Modified: 2014-01-02 15:39 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Heiko W. Rupp 2013-10-18 09:01:29 EDT
The rest-api landing page http://localhost:7080/rest/ still has a note about the api being non-stable.
We need to remove that.
Comment 1 Heiko W. Rupp 2013-10-18 09:24:25 EDT
master ea25b06
release/jon-3.2.x 0faf9f2
Comment 2 Simeon Pinder 2013-10-24 00:09:48 EDT
Moving to ON_QA for testing in the next build.
Comment 3 Filip Brychta 2013-11-13 10:12:13 EST
It is still there on ER5. There is another file..
[fbrychta@mylocal rhq]$ grep -r "Please note: the API is not stable at this point. Do not " .
./modules/enterprise/server/jar/src/main/resources/rest_templates/index.ftl:<strong>Please note: the API is not stable at this point. Do not rely on it.</strong><br/>
Comment 4 Heiko W. Rupp 2013-11-13 12:20:50 EST
Fixed in
master f4ef2cffd2
release branch 49e552ecb
Comment 5 Simeon Pinder 2013-11-19 10:48:14 EST
Moving to ON_QA as available for testing with new brew build.
Comment 6 Filip Brychta 2013-11-19 11:43:47 EST
Its still there on ER6. Release branch commit 49e552ecb didn't make it to rc/jon3.2.0.ER6
Comment 7 Simeon Pinder 2013-11-21 23:44:56 EST
Moving to ER07 target milestone and MODIFIED as initially rejected by QE because of bad ER6 build but put into varied states(MODIFIED & ASSIGNED).
Comment 8 Simeon Pinder 2013-11-22 00:01:45 EST
Moving to ON_QA as available to test in ER7 and later brew builds.
Comment 9 Filip Brychta 2013-11-22 04:27:54 EST
Verified on
Version :	
3.2.0.ER7
Build Number :	
e8e6401:ff0061d

Note You need to log in before you can comment on or make changes to this bug.