Bug 1020898 - If fedup upgrade fails due to a lack of disk space, it removes all the packages it downloaded
If fedup upgrade fails due to a lack of disk space, it removes all the packag...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: fedup (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Will Woods
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-18 09:27 EDT by David Howells
Modified: 2013-12-22 00:35 EST (History)
2 users (show)

See Also:
Fixed In Version: fedup-0.8.0-3.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-19 02:22:44 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Howells 2013-10-18 09:27:58 EDT
Description of problem:

If fedup's upgrade process fails due to a lack of disk space, then it removes all the packages it had downloaded for the upgrade, requiring them to be downloaded again.

upgrade-pre[652]: starting upgrade-pre hook                                     
upgrade[666]: starting upgrade hook                                             
upgrade[666]: preparing for upgrade...                                          
upgrade[666]: found 1262 packages to install                                    
upgrade[666]: building RPM transaction, one moment...                           
upgrade[666]: 1262 packages to install, 1190 to erase                           
upgrade[666]: checking RPM transaction...                                       
upgrade[666]: starting upgrade...                                               
upgrade[666]: preparing RPM transaction, one moment...                          
upgrade[666]: ERROR: upgrade failed due to the following problems:              
upgrade[666]: installing package valgrind-1:3.8.1-27.fc20.x86_64 needs 5MB on the / filesystem                                                                  
upgrade-post[675]: starting upgrade-post hook                                   
upgrade-post[675]: resetting bootloader config                                  
upgrade-post[675]: removing boot images                                         
upgrade-post[675]: removing downloaded packages                                 
upgrade-post[675]: removing miscellaneous files                                 

Version-Release number of selected component (if applicable):

fedup-0.7.3-4.fc18.noarch
yum-3.4.3-54.fc18.noarch
systemd-197-1.fc18.2.x86_64
rpm-4.10.3.1-3.fc18.x86_64
Comment 1 Will Woods 2013-10-18 11:52:21 EDT
Should be fixed in next release; see https://github.com/wgwoods/fedup-dracut/commit/aa8b0b9
Comment 2 Fedora Update System 2013-12-11 17:12:47 EST
fedup-0.8.0-3.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/fedup-0.8.0-3.fc19
Comment 3 Fedora Update System 2013-12-11 17:20:52 EST
fedup-0.8.0-3.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/fedup-0.8.0-3.fc20
Comment 4 Fedora Update System 2013-12-11 17:22:45 EST
fedup-0.8.0-3.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/fedup-0.8.0-3.fc18
Comment 5 Fedora Update System 2013-12-13 00:10:16 EST
Package fedup-0.8.0-3.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing fedup-0.8.0-3.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-23316/fedup-0.8.0-3.fc19
then log in and leave karma (feedback).
Comment 6 Fedora Update System 2013-12-19 02:22:44 EST
fedup-0.8.0-3.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 7 Fedora Update System 2013-12-19 20:44:59 EST
fedup-0.8.0-3.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Fedora Update System 2013-12-22 00:35:08 EST
fedup-0.8.0-3.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.