Bug 10209 - kernel: set_rtc_mmss: can't update
Summary: kernel: set_rtc_mmss: can't update
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel   
(Show other bugs)
Version: 6.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Michael K. Johnson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-03-16 16:35 UTC by Michael J. Rensing
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-16 03:00:59 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Michael J. Rensing 2000-03-16 16:35:02 UTC
running xntp3 on a dual processor Pentium III. xntp3 continually logs
errors of the form:

kernel: set_rtc_mmss: can't update from 50 to 4
kernel: set_rtc_mmss: can't update from 50 to 3
etc.

This is being logged in /var/log/messages, and in dmesg. It doesn't seem to
affect the time updates, but it fills the log, and obscures other more
significant problems.

Comment 1 Jeff Johnson 2000-05-14 20:56:59 UTC
The problem may be more than annoying, as SMP machines with certain BIOS'es
appear to not always be in sync (fixed in later kernel's, try the 6.2 SMP
kernel).

Note carefully that the message comes from the kernel, not xntp3, so I'm
changing the component ...

Comment 2 Adam Thompson 2000-07-26 17:49:05 UTC
This problem is consistently reproducable on ASUS P2B-DS motherboards running 
RH6.0.  It is also, interestingly, a problem for NetWare 5.0 on the same 
motherboard.

It does NOT occur in single-processor mode, whether enforced by software or 
hardware.  It only occurs in an SMP kernel running SMP hardware.

It is definitely fixed in RH6.2.


Comment 3 Michael J. Rensing 2000-08-01 16:06:22 UTC
My system is running SMP kernel 2.2.12 on an ASUS P2B-D motherboard.
Unfortunately, I can't easily upgrade because I have two critical drivers which
are dependent on the kernel version, and haven't been updated to the current
kernel yet.


Note You need to log in before you can comment on or make changes to this bug.