Bug 1020949 - Broken reading https page via port#8443
Broken reading https page via port#8443
Status: CLOSED CURRENTRELEASE
Product: OpenShift Online
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Jhon Honce
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-18 11:09 EDT by mzimen
Modified: 2015-05-14 19:30 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-29 19:49:13 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description mzimen 2013-10-18 11:09:46 EDT
Description of problem:
When reading page via https://...:8443/ it breaks in the middle with the following message (from curl):

* nread <= 0, server closed connection, bailing
* transfer closed with outstanding read data remaining
* Closing connection #0
* SSLv3, TLS alert, Client hello (1):
curl: (18) transfer closed with outstanding read data remaining

all other ports work correctly - http/80, http/8080, https/443

Version-Release number of selected component (if applicable):
   devenv-stage_496 (ami-ffce9e96) and recents devenv

How reproducible:
always

Steps to Reproduce:
1. create a php app
2. try to access it via https://....:8443/
3.

Actual results:


Expected results:
the output should not be broken.

Additional info:
Comment 1 Jhon Honce 2013-10-21 20:18:28 EDT
I cannot reproduce on devenv_3924
Comment 2 chunchen 2013-10-22 02:13:34 EDT
It cannot be reproduced on devenv_3926, so mark as VERIFIED
Comment 3 Chris Ryan 2013-11-20 07:37:30 EST
This is an issue on the latest devenv: devenv_4053 (ami-e1c5e288).

First, create a php app:
rhc create-app p1 php-5.3

Second, add a phpinfo.php file to the php/ directory in the app repo:
cd p1/php
touch phpinfo.php
echo "<?php phpinfo(); ?>" > phpinfo.php
git commit and git push

Third, try to curl the app url, specifically the :8443 port.
curl -k -X GET https://p1-testdomain1.dev.rhcloud.com:8443/phpinfo.php

You should notice that the full file is not output. It is cut off halfway, as compared to the other ports (80, 443, 8000, etc). Curl also exits with Exit Status 18, which, according to the man pages:
CURLE_PARTIAL_FILE (18)
A file transfer was shorter or larger than expected. This happens when the server first reports an expected transfer size, and then delivers data that doesn't match the previously given size. 

This also occurs with our ruby test framework.
Comment 4 Chris Ryan 2013-11-20 07:45:47 EST
I forgot to mention, run: echo $? after the curl command to see the exit status.

Note You need to log in before you can comment on or make changes to this bug.