Bug 1020954 - nova: cannot resize an instance
nova: cannot resize an instance
Status: CLOSED NOTABUG
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-nova (Show other bugs)
4.0
x86_64 Linux
unspecified Severity high
: ---
: 4.0
Assigned To: Vladan Popovic
Ami Jeain
storage
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-18 11:17 EDT by Dafna Ron
Modified: 2016-04-26 10:22 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-05 07:13:19 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
log (14.69 MB, application/x-xz)
2013-10-18 11:17 EDT, Dafna Ron
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1241659 None None None Never

  None (edit)
Description Dafna Ron 2013-10-18 11:17:51 EDT
Created attachment 813809 [details]
log

Description of problem:

I tried to resize an instance an even though --poll shows that the Instance resizing... 100% complete but nova list will show status as Active. 

Please note that I am working with glusterfs as cinder and glance backend. 

Version-Release number of selected component (if applicable):

openstack-nova-compute-2013.2-0.25.rc1.el6ost.noarch

How reproducible:

100%

Steps to Reproduce:
1. launch an instance 
2. resize image
3.

Actual results:

although --poll reports success the instance remains in status active and we cannot continue with the resize 

Expected results:

we should be able to resize the instance 

Additional info:


[root@cougar06 ~(keystone_admin)]# nova list 
+--------------------------------------+-------+--------+------------+-------------+--------------------------+
| ID                                   | Name  | Status | Task State | Power State | Networks                 |
+--------------------------------------+-------+--------+------------+-------------+--------------------------+
| ddec488f-8acd-4c46-a106-13f928325f7e | bla   | ACTIVE | None       | Running     | novanetwork=192.168.32.3 |
| 77dfe1cd-47f8-4320-8922-f4e0e25d1395 | dafna | ACTIVE | None       | Running     | novanetwork=192.168.32.5 |
| e7d5b6ea-f70d-44eb-80a0-1346a51e0734 | inst  | ACTIVE | None       | Running     | novanetwork=192.168.32.2 |
| c9b579bd-c392-4ab6-bdb8-ff5801f804cd | new   | ACTIVE | None       | Running     | novanetwork=192.168.32.6 |
| 8d384710-e67f-4db8-8526-b2e5c3dea05c | test  | ACTIVE | None       | Running     | novanetwork=192.168.32.4 |
+--------------------------------------+-------+--------+------------+-------------+--------------------------+
[root@cougar06 ~(keystone_admin)]# nova flavor-list 
+----+-----------+-----------+------+-----------+------+-------+-------------+-----------+
| ID | Name      | Memory_MB | Disk | Ephemeral | Swap | VCPUs | RXTX_Factor | Is_Public |
+----+-----------+-----------+------+-----------+------+-------+-------------+-----------+
| 1  | m1.tiny   | 512       | 1    | 0         |      | 1     | 1.0         | True      |
| 2  | m1.small  | 2048      | 20   | 0         |      | 1     | 1.0         | True      |
| 3  | m1.medium | 4096      | 40   | 0         |      | 2     | 1.0         | True      |
| 4  | m1.large  | 8192      | 80   | 0         |      | 4     | 1.0         | True      |
| 5  | m1.xlarge | 16384     | 160  | 0         |      | 8     | 1.0         | True      |
+----+-----------+-----------+------+-----------+------+-------+-------------+-----------+
[root@cougar06 ~(keystone_admin)]# nova resize c9b579bd-c392-4ab6-bdb8-ff5801f804cd m1.medium --poll
Instance resizing... 100% complete
Finished
[root@cougar06 ~(keystone_admin)]# nova list 
+--------------------------------------+-------+--------+------------+-------------+--------------------------+
| ID                                   | Name  | Status | Task State | Power State | Networks                 |
+--------------------------------------+-------+--------+------------+-------------+--------------------------+
| ddec488f-8acd-4c46-a106-13f928325f7e | bla   | ACTIVE | None       | Running     | novanetwork=192.168.32.3 |
| 77dfe1cd-47f8-4320-8922-f4e0e25d1395 | dafna | ACTIVE | None       | Running     | novanetwork=192.168.32.5 |
| e7d5b6ea-f70d-44eb-80a0-1346a51e0734 | inst  | ACTIVE | None       | Running     | novanetwork=192.168.32.2 |
| c9b579bd-c392-4ab6-bdb8-ff5801f804cd | new   | ACTIVE | None       | Running     | novanetwork=192.168.32.6 |
| 8d384710-e67f-4db8-8526-b2e5c3dea05c | test  | ACTIVE | None       | Running     | novanetwork=192.168.32.4 |
+--------------------------------------+-------+--------+------------+-------------+--------------------------+


/var/log/nova/compute.log:2013-10-18 17:59:43.796 2478 DEBUG nova.virt.disk.api [req-b4863e39-05b9-473c-a752-6fada31d9b04 bbce236d5aac4d1dbc086a8835ed0ebc d09f3bf0f9224affa92ab97010b37270] Unable to mount image /var/lib/nova/instances/c9b579bd-c392-4ab6-bdb8-ff5801f804cd/disk with error Error mounting /var/lib/nova/instances/c9b579bd-c392-4ab6-bdb8-ff5801f804cd/disk with libguestfs (mount_options: /dev/sda on / (options: ''): mount: you must specify the filesystem type). Cannot resize. is_image_partitionless /usr/lib/python2.6/site-packages/nova/virt/disk/api.py:183
Comment 1 Vladan Popovic 2013-12-03 09:17:36 EST
When deploying openstack on a single node, you need to add the following config params to be able to resize an instance on the same host:
allow_resize_to_same_host=True
scheduler_default_filters=AllHostsFilter (nova.conf only)

If you hit the same error, please check the scheduler.log and conductor.log as well as the compute.log to see what went wrong and paste/attach the output of aall of them.
Comment 5 Nikola Dipanov 2013-12-05 07:13:19 EST
Closing this as not a bug - these are well documented config option.

If you feel that packstack should set these options on --alinone feel free to open the bug on it.

We will not be changing this option in the packaging as it is a sane default for real world deployments. See #1025206 as we have already had the discussion there, for more details as to why this is.

Note You need to log in before you can comment on or make changes to this bug.