Bug 1020964 - Undefined method 'each' for nil:NilClass in update_configuration if application is invalid
Undefined method 'each' for nil:NilClass in update_configuration if applicati...
Status: CLOSED DUPLICATE of bug 1019109
Product: OpenShift Online
Classification: Red Hat
Component: Pod (Show other bugs)
2.x
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Lili Nader
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-18 11:33 EDT by Andy Goldstein
Modified: 2015-05-14 20:22 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-18 18:06:27 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andy Goldstein 2013-10-18 11:33:10 EDT
If an application has errors (such as a Deployment with 0 activations) and you try to update the application's configuration (e.g. to set keep-deployments), the broker will fail with an error.

On https://github.com/openshift/origin-server/blob/master/controller/app/models/application.rb#L408, self.errors.messages doesn't contain a key called :config. In my example, it contains :deployments=>["is invalid"].
Comment 1 Dan McPherson 2013-10-18 18:06:27 EDT

*** This bug has been marked as a duplicate of bug 1019109 ***

Note You need to log in before you can comment on or make changes to this bug.