Bug 1020978 - Dashboard throws error when logged in without Org
Dashboard throws error when logged in without Org
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Management (Show other bugs)
6.0.4
Unspecified Unspecified
unspecified Severity high (vote)
: Unspecified
: --
Assigned To: Walden Raines
Kedar Bidarkar
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-18 12:04 EDT by Mike McCune
Modified: 2014-04-24 13:10 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-04-24 13:09:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike McCune 2013-10-18 12:04:35 EDT
1) In Satellite 6 production mode (not Katello only) make sure you have multiple organizations defined beyond ACME_Corporation

2) Make sure you do *not* have a favorite Org saved in the list

3) Logout and login.  Dashboard throws error:

Error:
    undefined method `owner_info' for nil:NilClass


Full stacktrace:

https://gist.github.com/mccun934/7043776
Comment 2 Walden Raines 2013-10-18 16:15:07 EDT
PR:  https://github.com/Katello/katello/pull/3217
Comment 3 Walden Raines 2013-10-18 16:52:47 EDT
commit aa08a803bbd51ea389eb9cf5b75e2efacb1b9b61
Merge: fb8affe 7127dee
Author: Walden Raines <walden@redhat.com>
Date:   Fri Oct 18 13:52:09 2013 -0700

    Merge pull request #3217 from waldenraines/bug-1020978
    
    Bug #1020978 - only show available dashboard widgets on dashboard.

commit 7127dee5732edc2385f01320d9f426773a66b2d3
Author: Walden Raines <walden@redhat.com>
Date:   Fri Oct 18 16:13:11 2013 -0400

    Bug #1020978 - only show available dashboard widgets on dashboard.
Comment 4 Mike McCune 2013-10-19 17:45:27 EDT
*** Bug 1021145 has been marked as a duplicate of this bug. ***
Comment 7 Kedar Bidarkar 2013-10-22 09:55:34 EDT
Tested this with Satellite-6.0.2-RHEL-6-20131021.0, but we get the below traceback in production.log, this is same as seen in bug 1021145.



[ERROR 2013-10-22 19:21:57 app fc8b0c783620910e6c569c0e1716bce8 #15345] User does not belong to an organization. (Errors::SecurityViolation)
 | /usr/share/katello/app/controllers/application_controller.rb:272:in `require_org'
 | /opt/rh/ruby193/root/usr/share/gems/gems/activesupport-3.2.8/lib/active_support/callbacks.rb:440:in `_run__671789684561159885__process_action__4428405306115364545__callbacks'
 | /opt/rh/ruby193/root/usr/share/gems/gems/activesupport-3.2.8/lib/active_support/callbacks.rb:405:in `__run_callback'
 | /opt/rh/ruby193/root/usr/share/gems/gems/activesupport-3.2.8/lib/active_support/callbacks.rb:385:in `_run_process_action_callbacks'
 | /opt/rh/ruby193/root/usr/share/gems/gems/activesupport-3.2.8/lib/active_support/callbacks.rb:81:in `run_callbacks'
 | /opt/rh/ruby193/root/usr/share/gems/gems/actionpack-3.2.8/lib/abstract_controller/callbacks.rb:17:in `process_action'
 | /opt/rh/ruby193/root/usr/share/gems/gems/actionpack-3.2.8/lib/action_controller/metal/rescue.rb:29:in `process_action'
 | /opt/rh/ruby193/root/usr/share/gems/gems/actionpack-3.2.8/lib/action_controller/metal/instrumentation.rb:30:in `block in process_action'
 | /opt/rh/ruby193/root/usr/share/gems/gems/activesupport-3.2.8/lib/active_support/notifications.rb:123:in `block in instrument'
 | /opt/rh/ruby193/root/usr/share/gems/gems/activesupport-3.2.8/lib/active_support/notifications/instrumenter.rb:20:in `instrument'
 | /opt/rh/ruby193/root/usr/share/gems/gems/activesupport-3.2.8/lib/active_support/notifications.rb:123:in `instrument'
 | /opt/rh/ruby193/root/usr/share/gems/gems/actionpack-3.2.8/lib/action_controller/metal/instrumentation.rb:29:in `process_action'
 | /opt/rh/ruby193/root/usr/share/gems/gems/actionpack-3.2.8/lib/action_controller/metal/params_wrapper.rb:207:in `process_action'
 | /opt/rh/ruby193/root/usr/share/gems/gems/activerecord-3.2.8/lib/active_record/railties/controller_runtime.rb:18:in `process_action'
 | /opt/rh/ruby193/root/usr/share/gems/gems/actionpack-3.2.8/lib/abstract_controller/base.rb:121:in `process'
 | /opt/rh/ruby193/root/usr/share/gems/gems/actionpack-3.2.8/lib/abstract_controller/rendering.rb:45:in `process'
 | /opt/rh/ruby193/root/usr/share/gems/gems/actionpack-3.2.8/lib/action_controller/metal.rb:203:in `dispatch'
 | /opt/rh/ruby193/root/usr/share/gems/gems/actionpack-3.2.8/lib/action_controller/metal/rack_delegation.rb:14:in `dispatch'
 | /opt/rh/ruby193/root/usr/share/gems/gems/actionpack-3.2.8/lib/action_controller/metal.rb:246:in `block in action'
 | /opt/rh/ruby193/root/usr/share/gems/gems/actionpack-3.2.8/lib/action_dispatch/routing/route_set.rb:73:in `call'
Comment 8 Walden Raines 2013-10-22 13:22:08 EDT
(In reply to Kedar Bidarkar from comment #7)
> Tested this with Satellite-6.0.2-RHEL-6-20131021.0, but we get the below
> traceback in production.log, this is same as seen in bug 1021145.
> 
> 
> 
> [ERROR 2013-10-22 19:21:57 app fc8b0c783620910e6c569c0e1716bce8 #15345] User
> does not belong to an organization. (Errors::SecurityViolation)
>  | /usr/share/katello/app/controllers/application_controller.rb:272:in
> `require_org'
>  |
> /opt/rh/ruby193/root/usr/share/gems/gems/activesupport-3.2.8/lib/
> active_support/callbacks.rb:440:in
> `_run__671789684561159885__process_action__4428405306115364545__callbacks'
>  |
> /opt/rh/ruby193/root/usr/share/gems/gems/activesupport-3.2.8/lib/
> active_support/callbacks.rb:405:in `__run_callback'
>  |
> /opt/rh/ruby193/root/usr/share/gems/gems/activesupport-3.2.8/lib/
> active_support/callbacks.rb:385:in `_run_process_action_callbacks'
>  |
> /opt/rh/ruby193/root/usr/share/gems/gems/activesupport-3.2.8/lib/
> active_support/callbacks.rb:81:in `run_callbacks'
>  |
> /opt/rh/ruby193/root/usr/share/gems/gems/actionpack-3.2.8/lib/
> abstract_controller/callbacks.rb:17:in `process_action'
>  |
> /opt/rh/ruby193/root/usr/share/gems/gems/actionpack-3.2.8/lib/
> action_controller/metal/rescue.rb:29:in `process_action'
>  |
> /opt/rh/ruby193/root/usr/share/gems/gems/actionpack-3.2.8/lib/
> action_controller/metal/instrumentation.rb:30:in `block in process_action'
>  |
> /opt/rh/ruby193/root/usr/share/gems/gems/activesupport-3.2.8/lib/
> active_support/notifications.rb:123:in `block in instrument'
>  |
> /opt/rh/ruby193/root/usr/share/gems/gems/activesupport-3.2.8/lib/
> active_support/notifications/instrumenter.rb:20:in `instrument'
>  |
> /opt/rh/ruby193/root/usr/share/gems/gems/activesupport-3.2.8/lib/
> active_support/notifications.rb:123:in `instrument'
>  |
> /opt/rh/ruby193/root/usr/share/gems/gems/actionpack-3.2.8/lib/
> action_controller/metal/instrumentation.rb:29:in `process_action'
>  |
> /opt/rh/ruby193/root/usr/share/gems/gems/actionpack-3.2.8/lib/
> action_controller/metal/params_wrapper.rb:207:in `process_action'
>  |
> /opt/rh/ruby193/root/usr/share/gems/gems/activerecord-3.2.8/lib/
> active_record/railties/controller_runtime.rb:18:in `process_action'
>  |
> /opt/rh/ruby193/root/usr/share/gems/gems/actionpack-3.2.8/lib/
> abstract_controller/base.rb:121:in `process'
>  |
> /opt/rh/ruby193/root/usr/share/gems/gems/actionpack-3.2.8/lib/
> abstract_controller/rendering.rb:45:in `process'
>  |
> /opt/rh/ruby193/root/usr/share/gems/gems/actionpack-3.2.8/lib/
> action_controller/metal.rb:203:in `dispatch'
>  |
> /opt/rh/ruby193/root/usr/share/gems/gems/actionpack-3.2.8/lib/
> action_controller/metal/rack_delegation.rb:14:in `dispatch'
>  |
> /opt/rh/ruby193/root/usr/share/gems/gems/actionpack-3.2.8/lib/
> action_controller/metal.rb:246:in `block in action'
>  |
> /opt/rh/ruby193/root/usr/share/gems/gems/actionpack-3.2.8/lib/
> action_dispatch/routing/route_set.rb:73:in `call'

The error in the log is unrelated to this fix and is, in fact, expected behavior as far as I can tell.

The "generic dashboard" is also expected because you have not yet selected an org.  The error in this bug was related to attempting to display a dashboard widget that required an org without having one set.

Expected behavior is that you should get a dashboard without an org set and with only notifications being displayed.
Comment 9 sthirugn@redhat.com 2013-10-22 14:36:58 EDT
Verified.

The UI does not show "undefined method `owner_info' for nil:NilClass" error anymore. 

Version Tested:
* candlepin-0.8.25-1.el6sam.noarch
* candlepin-scl-1-5.el6_4.noarch
* candlepin-scl-quartz-2.1.5-5.el6_4.noarch
* candlepin-scl-rhino-1.7R3-1.el6_4.noarch
* candlepin-scl-runtime-1-5.el6_4.noarch
* candlepin-selinux-0.8.25-1.el6sam.noarch
* candlepin-tomcat6-0.8.25-1.el6sam.noarch
* elasticsearch-0.19.9-8.el6sat.noarch
* foreman-1.3.0-18.el6sat.noarch
* foreman-compute-1.3.0-18.el6sat.noarch
* foreman-libvirt-1.3.0-18.el6sat.noarch
* foreman-postgresql-1.3.0-18.el6sat.noarch
* foreman-proxy-1.3.0-3.el6sat.noarch
* katello-1.4.6-40.el6sat.noarch
* katello-all-1.4.6-40.el6sat.noarch
* katello-candlepin-cert-key-pair-1.0-1.noarch
* katello-certs-tools-1.4.4-1.el6sat.noarch
* katello-cli-1.4.3-24.el6sat.noarch
* katello-cli-common-1.4.3-24.el6sat.noarch
* katello-common-1.4.6-40.el6sat.noarch
* katello-configure-1.4.7-6.el6sat.noarch
* katello-configure-foreman-1.4.7-6.el6sat.noarch
* katello-foreman-all-1.4.6-40.el6sat.noarch
* katello-glue-candlepin-1.4.6-40.el6sat.noarch
* katello-glue-elasticsearch-1.4.6-40.el6sat.noarch
* katello-glue-pulp-1.4.6-40.el6sat.noarch
* katello-qpid-broker-key-pair-1.0-1.noarch
* katello-qpid-client-key-pair-1.0-1.noarch
* katello-selinux-1.4.4-4.el6sat.noarch
* pulp-katello-plugins-0.2-1.el6sat.noarch
* pulp-nodes-common-2.3.0-0.22.beta.el6sat.noarch
* pulp-nodes-parent-2.3.0-0.22.beta.el6sat.noarch
* pulp-puppet-plugins-2.3.0-0.22.beta.el6sat.noarch
* pulp-rpm-plugins-2.3.0-0.22.beta.el6sat.noarch
* pulp-selinux-2.3.0-0.22.beta.el6sat.noarch
* pulp-server-2.3.0-0.22.beta.el6sat.noarch
Comment 10 Bryan Kearney 2014-04-24 13:09:02 EDT
This was verified and delivered with MDP2. Closing it out.
Comment 11 Bryan Kearney 2014-04-24 13:10:38 EDT
This was delivered and verified with MDP2. Closing the bug.

Note You need to log in before you can comment on or make changes to this bug.