Bug 1020990 - fence_virtd segfault under normal usage
fence_virtd segfault under normal usage
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: fence-virt (Show other bugs)
6.5
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Ryan McCabe
cluster-qe@redhat.com
:
Depends On:
Blocks: 1164927
  Show dependency treegraph
 
Reported: 2013-10-18 12:48 EDT by michal novacek
Modified: 2016-05-11 04:52 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-14 17:01:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
"fence_virtd -F -d99" output (3.90 KB, text/plain)
2013-10-18 12:48 EDT, michal novacek
no flags Details

  None (edit)
Description michal novacek 2013-10-18 12:48:19 EDT
Created attachment 813854 [details]
"fence_virtd -F -d99" output

Description of problem:

hypervisor:bucek-03            <------>  hypervisor:doom-driver
  \_virtual:bucek-03-node01                \_virtual:doom-driver-node01

physical:doom-driver

I have two physical machines acting as hypervisors (bucek-03 and doom-driver)
each having one virtual machine named $(hostname -s)-node01. fence_virtd is
configured on both hypervisors to talk to each other using backend{} part in
config file and has 'serial' as listener{}.

fence_virtd segfaulted on bucek-03 after trying to off and on bucek-03-node01
from doom-driver-node01 using fence_virt.

fence_virtd[31689]: segfault at 0 ip 0000003c36b3383f sp 00007f5fe341ec58
error 4 in libc-2.12.so[3c36a00000+18b000]

Version-Release number of selected component (if applicable):
fence-virtd-serial-0.2.3-15.el6.x86_64

How reproducible: happened once

Steps to Reproduce:
seed additional info.

Additional info:
doom-driver-node01$ fence_virt -D /dev/ttyS1 -o list
bucek-03-node01      1893c3d4-77e6-4233-28ce-6b2c75d00981 on
doom-driver-node01$ fence_virt -D /dev/ttyS1 -H bucek-03-node01 -o status
doom-driver-node01$ fence_virt -D /dev/ttyS1 -H bucek-03-node01 -o off
doom-driver-node01$ fence_virt -D /dev/ttyS1 -H bucek-03-node01 -o status
doom-driver-node01$ echo $?
2
doom-driver-node01:~]$ fence_virt -D /dev/ttyS1 -o list
doom-driver-node01:~]$ fence_virt -D /dev/ttyS1 -H bucek-03-node01 -o on

fence_virtd segfaulted on bucek-03

Virtual machines are behind NAT.

There is a lot of 'libvir: XML-RPC error : Cannot write data: Broken pipe' which might have samething to do with that. This happened only once and I have not been able to reproduce it since.
Comment 2 Jaroslav Kortus 2013-10-18 13:11:10 EDT
any core files (/var/spool/abrt)?
Comment 3 michal novacek 2013-10-21 04:58:30 EDT
Unluckily no, because abrtd segfaulted collecting them.
Comment 8 Chris Feist 2015-10-14 17:01:24 EDT
Closing this bug since we haven't been able to reproduce this issue, please re-open if this issue is still present.

Note You need to log in before you can comment on or make changes to this bug.