This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1020999 - virsh change-media and --eject are not noticed by the guest
virsh change-media and --eject are not noticed by the guest
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: libvirt (Show other bugs)
22
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Libvirt Maintainers
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-18 13:59 EDT by Zbigniew Jędrzejewski-Szmek
Modified: 2016-04-26 10:11 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-04-15 14:04:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Zbigniew Jędrzejewski-Szmek 2013-10-18 13:59:15 EDT
Description of problem:
Following Fedora Virtualization Test Day, test http://fedoraproject.org/wiki/QA:Testcase_Virt_Change_CDROM_Media.

Connecting/disconnecting the CD through virt-manager GUI results in the guest noticing the change immediately.

Doing the same (I guess it should be the same) with virsh results in the CD being removed/changed but the guest doesn't notice it and thinks the old image is still present. Only when it is accessed, the new content is shown, or an error occurs.

Version-Release number of selected component (if applicable):
virt-manager-0.10.0-4.git79196cdf.fc20.noarch (host)
libvirt-client-1.1.3-2.fc20.x86_64 (host)
Fedora-20-Beta-TC5-x86_64 (guest)

How reproducible:
I tried a few times, seems to be always the case.

Steps to Reproduce:
1. attach /var/tmp/Fedora-20-Beta-TC5-x86_64-netinst.iso as cdrom to the guest
2. sudo virsh change-media f20 hda /var/tmp/Fedora-20-Beta-TC5-i386-netinst.iso
or
3. sudo virsh change-media f20 hda --eject

Actual results:
Guest doesn't notice the change.

Expected results:
Guest shows that the CD has been ejected or changed.
Comment 1 Cole Robinson 2015-04-15 14:04:52 EDT
FWIW this was working fine on f21 and f22, so just closing as CURRENTRELEASE since I don't think we will ever be tracking down + fixing the f20 bug

Note You need to log in before you can comment on or make changes to this bug.