Bug 1021 - loadlin clearing memory?
loadlin clearing memory?
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: lilo (Show other bugs)
5.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-02-01 18:24 EST by perry_hutchison
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-06-29 13:41:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description perry_hutchison 1999-02-01 18:24:43 EST
The component should be "loadlin" which is not in the list.

I have a locally-written program which needs to access the
BIOS image by reading /dev/mem.  It works properly when I
boot Linux using LILO, but if I boot using Loadlin the
pertinent part of /dev/mem seems to be all zero.  The
distribution does not appear to include the Loadlin source
code, so I have not yet been able to investigate further.

Red Hat 5.1, kernel 2.0.35-1, loadlin v1.6
Comment 1 David Lawrence 1999-02-04 17:04:59 EST
The source code for loadlin.exe is located also in the dosutils
directory of our cdrom as lodlin16.tgz. It is unfortunately in
assembly.
Comment 2 perry_hutchison 1999-02-04 17:29:59 EST
OK, found it.  I'd suggest packaging it as a source rpm, the way
the lilo source is packaged.

Getting back to the underlying issue, I've been in contact with the
author of Loadlin and it seems unlikely that this can be fixed easily
due to the complexity of Loadlin having to coexist with things like
himem.sys and emm386.sys; also I was probably just lucky that the
BIOS image was preserved when I booted using LILO.
Comment 3 Jay Turner 1999-06-29 13:41:59 EDT
Discarding as it is not a package that we maintain inhouse.  Requests
for loadlin should go through the package maintainer.

Note You need to log in before you can comment on or make changes to this bug.