Bug 1021013 - RHEL7 firstboot: missing option to skip Subscription Management Registration
RHEL7 firstboot: missing option to skip Subscription Management Registration
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: subscription-manager (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Devan Goodwin
John Sefler
: Regression, TestBlocker
: 1023868 1027313 (view as bug list)
Depends On:
Blocks: rhsm-rhel70
  Show dependency treegraph
 
Reported: 2013-10-18 14:48 EDT by John Sefler
Modified: 2014-06-17 20:27 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-13 06:37:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot of firstboot showing choice to register or not (80.83 KB, image/png)
2013-11-07 16:30 EST, John Sefler
no flags Details
firstboot-register-later (53.90 KB, image/png)
2013-11-07 17:55 EST, Sharath Dwaral
no flags Details

  None (edit)
Description John Sefler 2013-10-18 14:48:08 EDT
Description of problem:
Former RHEL5 and RHEL6 versions of firstboot with rhn-setup-gnome provided a function to skip choosing a server for Red Hat Registration updates.

This same functionality is needed in subscription-manager-firstboot for RHEL7 to skip registration to Red Hat Subscription Management.


Version-Release number of selected component (if applicable):
[root@jsefler-7 ~]# rpm -q subscription-manager-firstboot
subscription-manager-firstboot-1.10.4-1.el7.x86_64
Comment 4 Devan Goodwin 2013-11-06 14:27:40 EST
Workarounds, I have not tested but you can likely drop to a terminal and remove the subscription-manager-firstboot rpm, then re-start firstboot.

The issue is fixed in subscription-manager.git master 96c7d8f9caf9b6da99b7a5f81184caa723608128.

This should be present in RHEL 7 builds by the end of the week. You'll be looking for subscription-manager 1.10.6 or greater.
Comment 7 Devan Goodwin 2013-11-07 10:15:28 EST
*** Bug 1027313 has been marked as a duplicate of this bug. ***
Comment 9 John Sefler 2013-11-07 16:30:27 EST
Created attachment 821313 [details]
screenshot of firstboot showing choice to register or not

Verifying Version...

# rpm -q subscription-manager-firstboot firstboot
subscription-manager-firstboot-1.10.6-1.el7.x86_64
firstboot-19.3-1.el7.noarch


VERIFIED: The screenshot demonstrates the ability to skip registration in firstboot.

The screenshot also has some verbage circled in red that should be changed.

The address of an RHN Satellite or RHN Proxy  <=== no longer appropriate
The address of a Subscription Management Service  <=== matches the next panel
Comment 10 Sharath Dwaral 2013-11-07 17:55:57 EST
Created attachment 821332 [details]
firstboot-register-later

Version

# subscription-manager version
server type: This system is currently not registered.
subscription management server: Unknown
subscription-manager: 1.10.6-1.el7
python-rhsm: 1.10.6-1.el7


Can be see from the attachment that there is an option to skip firstboot registration.

VERIFIED
Comment 11 John Sefler 2013-11-08 10:01:44 EST
(In reply to John Sefler from comment #9)
> Created attachment 821313 [details]
> screenshot of firstboot showing choice to register or not
> 
> The screenshot also has some verbage circled in red that should be changed.
> 
Will be addressed by bug 1028221
Comment 12 John Sefler 2014-02-04 08:57:05 EST
*** Bug 1023868 has been marked as a duplicate of this bug. ***
Comment 13 Ludek Smid 2014-06-13 06:37:33 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.