Bug 1021018 - EAP6 plugin ignores rhq.agent.plugins.availability-scan.timeout setting and defaults to 10 seconds
Summary: EAP6 plugin ignores rhq.agent.plugins.availability-scan.timeout setting and d...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Operations Network
Classification: JBoss
Component: Plugin -- JBoss EAP 6
Version: JON 3.1.2
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: DR01
: JON 3.3.0
Assignee: Stefan Negrea
QA Contact: Mike Foley
URL:
Whiteboard:
Depends On:
Blocks: 1100432 1119501
TreeView+ depends on / blocked
 
Reported: 2013-10-18 19:45 UTC by dsteigne
Modified: 2018-12-03 20:23 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
It was discovered that the EAP 6 plug-in's method execution timeout ignored the rhq.agent.plugins.availability-scan.timeout setting. It persisted the EAP 6 scan timeout setting, which made the behavior of the scan timeout unpredictable. The fix now uses the container's availability timeout for sync availability checks and improves the usage plug-in configuration settings for asynchronous availability of server components.
Clone Of:
: 1100432 1119501 (view as bug list)
Environment:
Last Closed: 2014-12-11 14:04:33 UTC
Type: Bug


Attachments (Terms of Use)

Description dsteigne 2013-10-18 19:45:15 UTC
Description of problem:
EAP6 plugin ignores rhq.agent.plugins.availability-scan.timeout setting and defaults to 10 seconds.  If you increase the agent's availability scan timeout setting to 15 seconds the availability timeout on an EAP 6 server still remains at 10 seconds. The plug-ins method execution timeout isn't using the agent's availability timeout setting and should be.

Version-Release number of selected component (if applicable):
3.1.2

How reproducible:
Always

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 2 dsteigne 2014-01-10 12:17:54 UTC
It actually is defaulting to 5 seconds, not 10

Comment 3 Stefan Negrea 2014-02-11 19:56:31 UTC
I can confirm that the timeout is currently 10 seconds. This is the default for all AS7 operations. Very few operations have this timeout overridden or overridable. The avail check is done via :read-resource operation.

The requested change would need to be implemented across the board for availability checks of all AS7 resources, since there is not much gain if just some components get a configurable timeout. Also this is a shared setting, so changes to the setting itself will affect all other plugins that use it (eg. apache plugin).

Comment 4 Larry O'Leary 2014-02-14 01:54:38 UTC
Re-targeted to CP02 to reduce CP01 overall payload.

Comment 5 Stefan Negrea 2014-05-22 19:37:08 UTC
The change is now merged into the release/jon3.2.x branch. 

Here are the details of the implemented fix:
1) use container avail timeout for sync avail checks
2) fix the usage plugin configuration settings for async avail for server components

release/jon3.2.x branch commit:

https://github.com/rhq-project/rhq/commit/2ef9ad2dd2af728af3817baf946089b512609bc3

Comment 6 Simeon Pinder 2014-05-22 21:37:00 UTC
Moving this back to MODIFIED. Not yet available for QA until available in next productized build. Setting target to DR02.

Comment 7 Simeon Pinder 2014-05-30 15:54:41 UTC
Moving this bug to:
One-Off release as is EAP plugin pack update
block BZ 1088652 which tracks the next EAP plugin pack update release.

Comment 8 Simeon Pinder 2014-07-31 15:52:08 UTC
Moving to ON_QA as available to test with brew build of DR01: https://brewweb.devel.redhat.com//buildinfo?buildID=373993


Note You need to log in before you can comment on or make changes to this bug.