Bug 1021037 - IOException: Input/output error during read on /dev/vda
IOException: Input/output error during read on /dev/vda
Status: CLOSED DUPLICATE of bug 1000980
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-manager (Show other bugs)
6.4
x86_64 Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Giuseppe Scrivano
Virtualization Bugs
abrt_hash:6852403013798c489193d11fec5...
:
Depends On: 1000980
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-18 16:05 EDT by Jan Wildeboer
Modified: 2014-04-30 03:24 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-04-30 03:24:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Wildeboer 2013-10-18 16:05:00 EDT
Version-Release number of selected component:
anaconda-13.21.195

Additional info:
libreport version: 2.0.9
cmdline:        /usr/bin/python  /usr/bin/anaconda
kernel:         2.6.32-358.el6.x86_64

description:
:The following was filed automatically by anaconda:
:anaconda 13.21.195 exception report
:Traceback (most recent call first):
:  File "/usr/lib64/python2.6/site-packages/parted/disk.py", line 213, in commit
:    return self.__disk.commit()
:  File "/usr/lib64/python2.6/site-packages/parted/decorators.py", line 31, in localeC
:    ret = fn(*args, **kwds)
:  File "<string>", line 2, in commit
:  File "/usr/lib/anaconda/storage/formats/disklabel.py", line 256, in commit
:    self.partedDisk.commit()
:  File "/usr/lib/anaconda/storage/formats/disklabel.py", line 235, in create
:    self.commit()
:  File "/usr/lib/anaconda/storage/deviceaction.py", line 290, in execute
:    options=self.device.formatArgs)
:  File "/usr/lib/anaconda/storage/devicetree.py", line 718, in processActions
:    action.execute(intf=self.intf)
:  File "/usr/lib/anaconda/storage/__init__.py", line 355, in doIt
:    self.devicetree.processActions()
:  File "/usr/lib/anaconda/packages.py", line 110, in turnOnFilesystems
:    anaconda.id.storage.doIt()
:  File "/usr/lib/anaconda/dispatch.py", line 210, in moveStep
:    rc = stepFunc(self.anaconda)
:  File "/usr/lib/anaconda/dispatch.py", line 126, in gotoNext
:    self.moveStep()
:  File "/usr/lib/anaconda/gui.py", line 1476, in setScreen
:    self.anaconda.dispatch.gotoNext()
:  File "/usr/lib/anaconda/gui.py", line 1389, in nextClicked
:    self.setScreen ()
:IOException: Input/output error during read on /dev/vda
Comment 2 Jan Wildeboer 2013-10-18 17:12:37 EDT
This happened when I created a LV ion virt-manager. Repeatedly.

Solution: Create the LV manually and use that LV in virt-manager. After I did that, the VM installed properly.

Background:

On a HP N40L Microserver, with 2x 2TB drives as a RAID1 with a VG spanning the whole 2 TB.
Comment 3 Dave Allan 2013-10-18 17:27:40 EDT
(In reply to Jan Wildeboer from comment #2)
> This happened when I created a LV ion virt-manager. Repeatedly.
> 
> Solution: Create the LV manually and use that LV in virt-manager. After I
> did that, the VM installed properly.

Hi Jan, so just to make sure I'm understanding what happened:

You created a VM with virt-manager, then
tried to create the LV to back the VM's vda with virt-manager, but
when you went to install the guest anaconda threw an exception.

If you create the LV manually and then hand the manually created LV to the VM as vda's backing storage, everything works as expected.

Do I have that right?
Comment 4 Jan Wildeboer 2013-10-19 04:46:47 EDT
Yes, that is correct. It seems to be the (rather confusing) option in the LV creation dialog with Max Capacity versus Allocation.

When I set Max Capacity to something (say 8000 MB), the Allocation stays at 0. And things go wrong. However, I guess I just have to set Allocation to a non-zero value to avoid this problem.

IMHO the allocation field should default to Max Capacity to avoid this problem.
Comment 5 Jan Wildeboer 2013-10-19 05:10:57 EDT
Just tested. And yes. When Allocation is set to a non-zero value, the problem doesn't show up.

Suggestion: Either set Allocation to a fitting non-zero value or (better IMHO) sync Allocation to Max Size, just as we do with memory setting.

At the very least setting Allocation to zero should cause an error as it is a non-working configuration.
Comment 6 Jan Wildeboer 2013-10-19 10:45:55 EDT
This seems to be fixed upstream already using the sync option.
Comment 7 Martin Kletzander 2013-10-21 05:17:08 EDT
This is fixed upstream with:

commit 590c8dbebfddb71874de7a98e579264ebae6859f
Author: Martin Kletzander <mkletzan@redhat.com>
Date:   Tue Apr 2 13:51:28 2013 +0200

    Don't support sparse logical volumes
Comment 9 Giuseppe Scrivano 2014-04-30 03:24:44 EDT

*** This bug has been marked as a duplicate of bug 1000980 ***

Note You need to log in before you can comment on or make changes to this bug.