Bug 1021052 - Inverted function key
Inverted function key
Status: CLOSED DUPLICATE of bug 1031745
Product: Fedora
Classification: Fedora
Component: kde-workspace (Show other bugs)
20
i386 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-18 17:39 EDT by Joseph Pesco
Modified: 2013-12-14 16:21 EST (History)
18 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-14 16:21:18 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joseph Pesco 2013-10-18 17:39:59 EDT
Description of problem:

Having installed Fedora 20 i386 Alpha to a 32G sd card on my Acer 725-0412 I next performed the upgrade that was called for of aproximately 425 packages.  

On rebooting the sense of the function key was inverted.  The keypad symbols in blue are enabled and the function key must be depressed to enter the other symbols in white.   


Version-Release number of selected component (if applicable):


How reproducible:

I'm going to attempt to reproduce this soon by using a 16G sd card allowing the original installation on the 32G sd card to be available.  

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Bill Nottingham 2013-10-21 12:12:49 EDT
Special keys are usually handled in the kernel.
Comment 2 Joseph Pesco 2013-10-21 14:14:02 EDT
1. The function key inverted iself after fewer than 100 key strokes.  
   I went back to play with problem installation and found that after some use the key sense righted itself.  I rebooted several times and each time the function key worked correctly after some use.  

2. I installed f20 i386 on the 16G sd Card as planned though I didn't have the time to perform an upgrade.
Comment 3 Joseph Pesco 2013-10-23 09:29:19 EDT
1. Booted the Alpha kernel 3.11.0-300 and found the function key remained inverted.  

2. Pressing the function key + F11/NumLk seems to solve the problem if only for a short time. The combination of keys must sometimes be tried several times before seeing the desired effect.
Comment 4 Joseph Pesco 2013-10-23 10:56:25 EDT
BTW.  While in: System Settings | Input Devices | Keyboard | "Numlock on KDE Startup" or "Keyboard Model" doesn't seem to be effective.
Comment 5 Joseph Pesco 2013-11-17 20:45:04 EST
Just installed f20 beta x86_64 lxde and there is no sign of this problem.  I'll try an install of f20 x86 beta with kde asap.
Comment 6 Joseph Pesco 2013-11-19 20:52:55 EST
Just installed f20 x86 beta kde onto a 32G sd card.
The function key reamains inverted.
Comment 7 Josh Boyer 2013-11-20 09:13:43 EST
So F20 Beta LXDE works fine, and F20 Beta KDE doesn't?  Those images share the same kernel, so this isn't a kernel issue.
Comment 8 Rex Dieter 2013-11-20 10:07:55 EST
Numlock turns on at login screen or after logged in?
Comment 9 Joseph Pesco 2013-12-01 16:24:21 EST
Yes, thank you I'm using the LXDE installation while I type.  Holidays do get in the way of things.  I've not yet done a minimum install though I might have the need and the time to do one soon.
Comment 10 Kevin Kofler 2013-12-01 17:30:14 EST
You haven't answered Rex Dieter's question:
> Numlock turns on at login screen or after logged in?
Comment 11 Joseph Pesco 2013-12-14 14:07:43 EST
Sorry for the delay Rex, Kevin... 

I believe the numlock is on at login, because after booting typing the "O/6" key results in the 6 character being displayed.  After hitting fn+NumLk an O is presented.  I've also got to hit fn+F7 to get the tracpad functioning on boot.  

1. I just did the minimum installation of f20 beta (x86_64 from dvd on to a 32Gsd) with no sign of the inverted NumLk: the keyboard functions properly on bootup.  

3. Directly after the minimum installation I did a `> yum groups install "KDE Plasma Desktop"' and rebooted.  The machine booted with the non graphical Plymouth and the keyboard functioned correctly at login.  

4. Once in I typed `> startx' to get the kde desktop and again the keyboard sense is correct.             

In summary: I've two 32Gsd 40MB/s Cards.  The second 32Gsd is an f20 Alpha x86 kde desktop installed on 10/11/13 from dvd that I first noticed the inverted Numlok with.  It has been faithfully upgrading since 10/11/13 and still the Numlk is inverted.  I clobbered the installation from comment 6 to do this installation.

For reasons other than this bug I started installing x86_64 during the testing cycle after having installed the Alpha as x86.  KDE is a bit sluggish on slower sd cards on my dinky Acer Aspire 725.  LXDE is fine even on slower sd cards, but Konqueror has features I like and use often.  (For a real illusion of speed putting  DocumentRoot on the same device as the OS is thrilling.)   I've several smaller equally fast sd cards that I could juggle and test with.

If I can be of further help feel free... 

joe
Comment 12 Kevin Kofler 2013-12-14 16:21:18 EST

*** This bug has been marked as a duplicate of bug 1031745 ***

Note You need to log in before you can comment on or make changes to this bug.