Bug 1021077 - Decreasing max-threads on a unbounded queuesless executor generates IllegalArgumentException
Decreasing max-threads on a unbounded queuesless executor generates IllegalAr...
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Server (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity unspecified
: ER7
: EAP 6.2.0
Assigned To: Aaron Ogburn
Russell Dickenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-19 03:14 EDT by Jay SenSharma
Modified: 2015-07-19 20:59 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-15 11:20:21 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker WFLY-2336 Minor Resolved Decreasing max-threads on a unbounded queueless executor generates IllegalArgumentException 2015-07-20 20:57:39 EDT

  None (edit)
Description Jay SenSharma 2013-10-19 03:14:38 EDT
Description of problem:


Create an unbounded queueless executor
${quote}
    <unbounded-queue-thread-pool name="uq-thread-pool">
         <max-threads count="350"/>
         <keepalive-time time="5" unit="minutes"/>
    </unbounded-queue-thread-pool>
${quote}

Modifying max-threads fails:
${quote}
/subsystem=threads/unbounded-queue-thread-pool=uq-thread-pool:write-attribute(name=max-threads,value=300)
{ "outcome" => "failed", "failure-description" => "JBAS014749: Operation handler failed: null", "rolled-back" => true }
${quote}

ERROR [org.jboss.as.controller.management-operation] (management-handler-thread - 1) JBAS014612: Operation ("write-attribute") failed - address: ([
("subsystem" => "threads"),
("unbounded-queue-thread-pool" => "uq-thread-pool")
]): java.lang.IllegalArgumentException
at java.util.concurrent.ThreadPoolExecutor.setMaximumPoolSize(ThreadPoolExecutor.java:1620) [rt.jar:1.7.0]
at org.jboss.threads.JBossThreadPoolExecutor.setMaxThreads(JBossThreadPoolExecutor.java:95) [jboss-threads-2.1.1.Final.jar:2.1.1.Final]
at org.jboss.as.threads.ManagedJBossThreadPoolExecutorService.setMaxThreads(ManagedJBossThreadPoolExecutorService.java:86)
at org.jboss.as.threads.UnboundedQueueThreadPoolService.setMaxThreads(UnboundedQueueThreadPoolService.java:91)

The core pool size needs to be adjusted in line with the max pool size and in the right order to avoid that since max threads can't be less than core threads.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 JBoss JIRA Server 2013-10-25 14:56:00 EDT
Aaron Ogburn <aogburn@redhat.com> made a comment on jira WFLY-2336

Merged now upstream so this can be closed.
Comment 2 JBoss JIRA Server 2013-10-25 14:56:38 EDT
Aaron Ogburn <aogburn@redhat.com> updated the status of jira WFLY-2336 to Resolved
Comment 3 Aaron Ogburn 2013-10-25 15:31:57 EDT
PR:

https://github.com/jbossas/jboss-eap/pull/636
Comment 6 Brian Stansberry 2013-10-28 17:08:26 EDT
I don't know who the QE contact should, be, but as it was acked, it's now merged.
Comment 7 Ladislav Thon 2013-11-14 09:37:01 EST
Verified with EAP 6.2.0.CR1.

Note You need to log in before you can comment on or make changes to this bug.