Bug 1021083 - boot with root on LVM broken by a change in dracut-034-18.git20131018.fc20
boot with root on LVM broken by a change in dracut-034-18.git20131018.fc20
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: dracut (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: dracut-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-19 04:24 EDT by Michal Schmidt
Modified: 2013-10-23 21:40 EDT (History)
3 users (show)

See Also:
Fixed In Version: dracut-034-19.git20131021.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-23 21:40:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Schmidt 2013-10-19 04:24:54 EDT
After upgrading to dracut-034-18.git20131018.fc20 my system does not boot. Regenerating the initramfs with the previous dracut build (dracut-034-8.git20131008.fc20) fixes the problem.
My root filesystem is on an LVM logical volume.
A diff between the working and the broken initramfs shows this suspicious hunk:

diff -Nurp good/etc/cmdline.d/90lvm.conf bad/etc/cmdline.d/90lvm.conf
--- good/etc/cmdline.d/90lvm.conf       2013-10-19 09:56:37.000000000 +0200
+++ bad/etc/cmdline.d/90lvm.conf        2013-10-19 10:03:03.000000000 +0200
@@ -1 +1 @@
- rd.lvm.lv=nonraidvg/swap rd.lvm.lv=nonraidvg/F-root
+ rd.lvm.lv=nonraidvg/swap nonraidvg/F-root

This line seems to be generated by the looped touched by the fix for bug 1013767, so I suspect that this is what caused the regression.
(Seems that "$line" now contains all the values from get_host_lvs at once, instead of being assigned one after another in the loop.)

As a workaround I can add "rd.lvm.lv=nonraidvg/F-root" to the kernel command line and boot successfully.

Version-Release number of selected component (if applicable):
dracut-034-18.git20131018.fc20
Comment 1 Chris Murphy 2013-10-20 18:05:47 EDT
I'm unable to reproduce this in qemu/kvm:
1. Boot Fedora-Live-Desktop-x86_64-20-Beta-TC5.iso, and install using guided partitioning default (conventional LVM); and reboot.
2. yum update dracut
3. dracut -f
4. reboot.

System does reboot.
Comment 2 Fedora Update System 2013-10-21 04:05:25 EDT
dracut-034-19.git20131021.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/dracut-034-19.git20131021.fc20
Comment 3 Fedora Update System 2013-10-21 14:27:10 EDT
Package dracut-034-19.git20131021.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing dracut-034-19.git20131021.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-19603/dracut-034-19.git20131021.fc20
then log in and leave karma (feedback).
Comment 4 Fedora Update System 2013-10-23 21:40:15 EDT
dracut-034-19.git20131021.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.