Bug 1021098 - brcmsmac driver - wireless led is not working with 64bit kernel
brcmsmac driver - wireless led is not working with 64bit kernel
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: fedora-kernel-wireless-brcm80211
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-19 07:36 EDT by Massimiliano
Modified: 2014-01-14 03:37 EST (History)
9 users (show)

See Also:
Fixed In Version: kernel-3.12.7-300.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-14 03:34:12 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
config-3.12.6-200.fc19.x86_64 (132.29 KB, text/plain)
2014-01-06 05:38 EST, Massimiliano
no flags Details
config-3.12.6-200.fc19.i686 (135.49 KB, text/plain)
2014-01-06 05:39 EST, Massimiliano
no flags Details

  None (edit)
Description Massimiliano 2013-10-19 07:36:52 EDT
Description of problem:
Wireless led doesn't turn on with 64bit kernel, but wireless networking works. It turns on/off only with 32bit kernel. I've blacklisted b43 module in 64bit system without success. In 32bit system b43 module is on.

Version-Release number of selected component (if applicable):
# lsmod | grep -i brcm
brcmsmac              526596  0 
cordic                 12525  1 brcmsmac
brcmutil               14880  1 brcmsmac
mac80211              564808  1 brcmsmac
cfg80211              460310  2 brcmsmac,mac80211
bcma                   40955  1 brcmsmac

# uname -r
3.11.4-201.fc19.x86_64

# lspci -vnn | grep -i bcm
01:00.0 Ethernet controller [0200]: Broadcom Corporation NetLink BCM57780 Gigabit Ethernet PCIe [14e4:1692] (rev 01)
02:00.0 Network controller [0280]: Broadcom Corporation BCM43225 802.11b/g/n [14e4:4357] (rev 01)
        Kernel driver in use: bcma-pci-bridge

How reproducible:
Always

Expected results:
The behaviour should be the same with both architectures.

Additional info:
The wireless led works with a 32bit live-respin:
$ uname -a
Linux localhost 3.11.3-201.fc19.i686 #1 SMP Thu Oct 3 01:25:06 UTC 2013 i686 i686 i386 GNU/Linux

$ lsmod | grep brcmsmac
brcmsmac              503016  0 
cordic                 12477  1 brcmsmac
brcmutil               14440  1 brcmsmac
mac80211              482086  2 b43,brcmsmac
cfg80211              390865  3 b43,brcmsmac,mac80211
bcma                   39889  3 b43,brcmsmac

$ lsmod | grep b43
b43                   360991  0 
mac80211              482086  2 b43,brcmsmac
cfg80211              390865  3 b43,brcmsmac,mac80211
ssb                    55816  1 b43
mmc_core              103158  2 b43,ssb
bcma                   39889  3 b43,brcmsmac
Comment 1 Justin M. Forbes 2014-01-03 17:09:57 EST
*********** MASS BUG UPDATE **************

We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 19 kernel bugs.

Fedora 19 has now been rebased to 3.12.6-200.fc19.  Please test this kernel update (or newer) and let us know if you issue has been resolved or if it is still present with the newer kernel.

If you have moved on to Fedora 20, and are still experiencing this issue, please change the version to Fedora 20.

If you experience different issues, please open a new bug report for those.
Comment 2 Massimiliano 2014-01-05 16:06:15 EST
Kernel 3.12.6-200.fc19.x86_64 doesn't solve the problem: the led still doesn't turn on.
Comment 3 Arend van Spriel 2014-01-05 16:30:41 EST
(In reply to Massimiliano from comment #2)
> Kernel 3.12.6-200.fc19.x86_64 doesn't solve the problem: the led still
> doesn't turn on.

Can you provide the kernel configuration for x86_64 and i386 kernels?
Comment 4 Massimiliano 2014-01-05 16:40:18 EST
What do you mean? This is the kernel from updates (no special configuration). I have tested the 64bit kernel only (I suppose the 32bit version is still working, I hope).

$ rpm -qi kernel-3.12.6-200.fc19.x86_64
Name        : kernel
Version     : 3.12.6
Release     : 200.fc19
Architecture: x86_64
Install Date: sab 04 gen 2014 10:25:08 CET
Group       : System Environment/Kernel
Size        : 136841859
License     : GPLv2 and Redistributable, no modification permitted
Signature   : RSA/SHA256, mar 24 dic 2013 15:51:25 CET, Key ID 07477e65fb4b18e6
Source RPM  : kernel-3.12.6-200.fc19.src.rpm
Build Date  : lun 23 dic 2013 17:56:49 CET
Build Host  : bkernel01.phx2.fedoraproject.org
Relocations : (not relocatable)
Packager    : Fedora Project
Vendor      : Fedora Project
URL         : http://www.kernel.org/
Summary     : The Linux kernel
Description :
The kernel package contains the Linux kernel (vmlinuz), the core of any
Linux operating system.  The kernel handles the basic functions
of the operating system: memory allocation, process allocation, device
input and output, etc.
Comment 5 Arend van Spriel 2014-01-06 03:41:44 EST
(In reply to Massimiliano from comment #4)
> What do you mean? This is the kernel from updates (no special
> configuration). I have tested the 64bit kernel only (I suppose the 32bit
> version is still working, I hope).

I mean the /boot/config--3.12.6-200.fc19.x86_64 file. I am not using Fedora on my systems so it would help me, and possibly yourself, if you can attach it to this bugzilla.
Comment 6 Massimiliano 2014-01-06 05:38:15 EST
Created attachment 846013 [details]
config-3.12.6-200.fc19.x86_64
Comment 7 Massimiliano 2014-01-06 05:39:18 EST
Created attachment 846014 [details]
config-3.12.6-200.fc19.i686
Comment 8 Massimiliano 2014-01-06 05:42:02 EST
(In reply to Arend van Spriel from comment #5)
> I mean the /boot/config--3.12.6-200.fc19.x86_64 file.
Ok, see attachments.

> I am not using Fedora on my systems so it would help me, and possibly yourself, > if you can attach it to this bugzilla.
Of course. I didn't realize that you are not using Fedora, since we are in a Fedora bugzilla.
Comment 9 John Greene 2014-01-06 10:59:41 EST
It would appear that your 32 bit live respin has loaded both drivers brcmsmac and b43 which cause a hard situation to isolate.  

The device you list does support both b43 and brcmsmac. 
 

LiveCD I assume you are using solely as an isolation of issue and don't want to 
install, yes?  If so, an easy test for you.  I'm wondering if the b43 driver loaded alongside the brcmsmac is masking the issue in 32 bit brcmsmac driver.

Can you try your test with the following? 

# remove all the drivers bcm for your h/w

modprobe -r b43 bcma
modprobe -r brcmsmac bcma
modprobe -r wl

# then just load brcmsmac

modprobe brcmsmac

Do you still have the LED issue? 
Apples to apples test..
Comment 10 Arend van Spriel 2014-01-08 03:32:12 EST
I have taken a look at the two config files. The brcmsmac driver depends on BCMA_DRIVER_GPIO for led support. In the 32 bit config this option is enabled, but not in the 64 bit config. Therefor no led support in brcmsmac.
Comment 11 Josh Boyer 2014-01-08 07:29:54 EST
Thanks Arend.  We'll look at enabling BCMA_DRIVER_GPIO everywhere.
Comment 12 Josh Boyer 2014-01-08 07:56:45 EST
Changed in Fedora git.
Comment 13 Fedora Update System 2014-01-11 11:16:34 EST
kernel-3.12.7-300.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/kernel-3.12.7-300.fc20
Comment 14 Fedora Update System 2014-01-11 11:20:06 EST
kernel-3.12.7-200.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/kernel-3.12.7-200.fc19
Comment 15 Fedora Update System 2014-01-11 23:59:30 EST
Package kernel-3.12.7-200.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kernel-3.12.7-200.fc19'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-0684/kernel-3.12.7-200.fc19
then log in and leave karma (feedback).
Comment 16 Fedora Update System 2014-01-14 03:34:12 EST
kernel-3.12.7-200.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 17 Fedora Update System 2014-01-14 03:37:29 EST
kernel-3.12.7-300.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.