Bug 1021100 - File "/usr/lib/python2.7/site-packages/dnf/package.py", line 109, in repo return self.yumbase.repos[self.reponame] KeyError: '@System'
File "/usr/lib/python2.7/site-packages/dnf/package.py", line 109, in repo ...
Status: CLOSED DUPLICATE of bug 1021087
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-19 07:53 EDT by Nicolas Mailhot
Modified: 2013-10-20 01:52 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-20 01:52:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nicolas Mailhot 2013-10-19 07:53:53 EDT
tem'
[nim@arekh ~]$  sudo dnf -y update 
Configuration du processus de mise à jour
Resolving dependencies
--> Starting dependency resolution
---> Package kernel.x86_64 3.12.0-0.rc5.git2.1.fc21 will be installé
---> Package atlas.x86_64 3.10.1-6.fc21 will be upgraded
---> Package atlas.x86_64 3.10.1-6.fc21 will be an upgrade
---> Package autocorr-en.noarch 1:4.1.2.3-3.fc19 will be upgraded
---> Package autocorr-en.noarch 1:4.1.2.3-3.fc19 will be an upgrade
---> Package autogen-libopts.x86_64 5.18.1-1.fc21 will be upgraded
---> Package autogen-libopts.x86_64 5.18.1-1.fc21 will be an upgrade
---> Package avr-gcc.x86_64 4.8.1-2.fc20 will be upgraded
---> Package avr-gcc.x86_64 4.8.1-2.fc20 will be an upgrade
---> Package bluez.x86_64 5.9-4.fc21 will be upgraded
---> Package bluez.x86_64 5.9-4.fc21 will be an upgrade
---> Package bluez-cups.x86_64 5.9-4.fc21 will be upgraded
---> Package bluez-cups.x86_64 5.9-4.fc21 will be an upgrade
---> Package bluez-libs.x86_64 5.9-4.fc21 will be upgraded
---> Package bluez-libs.x86_64 5.9-4.fc21 will be an upgrade
---> Package cpp.x86_64 4.8.1-10.fc21 will be upgraded
---> Package cpp.x86_64 4.8.1-10.fc21 will be an upgrade
---> Package gcc.x86_64 4.8.1-10.fc21 will be upgraded
---> Package gcc.x86_64 4.8.1-10.fc21 will be an upgrade
---> Package libgcc.x86_64 4.8.1-10.fc21 will be upgraded
---> Package libgcc.x86_64 4.8.1-10.fc21 will be an upgrade
---> Package libgomp.x86_64 4.8.1-10.fc21 will be upgraded
---> Package libgomp.x86_64 4.8.1-10.fc21 will be an upgrade
---> Package cups-filters.x86_64 1.0.40-2.fc21 will be upgraded
---> Package cups-filters.x86_64 1.0.40-2.fc21 will be an upgrade
---> Package cups-filters-libs.x86_64 1.0.40-2.fc21 will be upgraded
---> Package cups-filters-libs.x86_64 1.0.40-2.fc21 will be an upgrade
---> Package dom4j-manual.noarch 1.6.1-18.fc20 will be upgraded
---> Package dom4j-manual.noarch 1.6.1-18.fc20 will be an upgrade
---> Package eventlog.x86_64 0.2.13-3.fc20 will be upgraded
---> Package eventlog.x86_64 0.2.13-3.fc20 will be an upgrade
---> Package firefox.x86_64 24.0-1.fc21 will be upgraded
---> Package firefox.x86_64 24.0-1.fc21 will be an upgrade
---> Package gnome-classic-session.noarch 3.10.0-1.fc21 will be upgraded
---> Package gnome-classic-session.noarch 3.10.0-1.fc21 will be an upgrade
---> Package gnome-shell-extension-alternate-tab.noarch 3.10.0-1.fc21 will be upgraded
---> Package gnome-shell-extension-alternate-tab.noarch 3.10.0-1.fc21 will be an upgrade
---> Package gnome-shell-extension-apps-menu.noarch 3.10.0-1.fc21 will be upgraded
---> Package gnome-shell-extension-apps-menu.noarch 3.10.0-1.fc21 will be an upgrade
---> Package gnome-shell-extension-auto-move-windows.noarch 3.10.0-1.fc21 will be upgraded
---> Package gnome-shell-extension-auto-move-windows.noarch 3.10.0-1.fc21 will be an upgrade
---> Package gnome-shell-extension-common.noarch 3.10.0-1.fc21 will be upgraded
---> Package gnome-shell-extension-common.noarch 3.10.0-1.fc21 will be an upgrade
---> Package gnome-shell-extension-drive-menu.noarch 3.10.0-1.fc21 will be upgraded
---> Package gnome-shell-extension-drive-menu.noarch 3.10.0-1.fc21 will be an upgrade
---> Package gnome-shell-extension-launch-new-instance.noarch 3.10.0-1.fc21 will be upgraded
---> Package gnome-shell-extension-launch-new-instance.noarch 3.10.0-1.fc21 will be an upgrade
---> Package gnome-shell-extension-native-window-placement.noarch 3.10.0-1.fc21 will be upgraded
---> Package gnome-shell-extension-native-window-placement.noarch 3.10.0-1.fc21 will be an upgrade
---> Package gnome-shell-extension-places-menu.noarch 3.10.0-1.fc21 will be upgraded
---> Package gnome-shell-extension-places-menu.noarch 3.10.0-1.fc21 will be an upgrade
---> Package gnome-shell-extension-systemMonitor.noarch 3.10.0-1.fc21 will be upgraded
---> Package gnome-shell-extension-systemMonitor.noarch 3.10.0-1.fc21 will be an upgrade
---> Package gnome-shell-extension-user-theme.noarch 3.10.0-1.fc21 will be upgraded
---> Package gnome-shell-extension-user-theme.noarch 3.10.0-1.fc21 will be an upgrade
---> Package gnome-shell-extension-window-list.noarch 3.10.0-1.fc21 will be upgraded
---> Package gnome-shell-extension-window-list.noarch 3.10.0-1.fc21 will be an upgrade
---> Package gnome-shell-extension-windowsNavigator.noarch 3.10.0-1.fc21 will be upgraded
---> Package gnome-shell-extension-windowsNavigator.noarch 3.10.0-1.fc21 will be an upgrade
---> Package gnome-shell-extension-workspace-indicator.noarch 3.10.0-1.fc21 will be upgraded
---> Package gnome-shell-extension-workspace-indicator.noarch 3.10.0-1.fc21 will be an upgrade
---> Package gnome-shell-theme-zukitwo.noarch 20130424-2.fc20 will be upgraded
---> Package gnome-shell-theme-zukitwo.noarch 20130424-2.fc20 will be an upgrade
---> Package gnutls.x86_64 3.1.13-2.fc20 will be upgraded
---> Package gnutls.x86_64 3.1.13-2.fc20 will be an upgrade
---> Package gnutls-dane.x86_64 3.1.13-2.fc20 will be upgraded
---> Package gnutls-dane.x86_64 3.1.13-2.fc20 will be an upgrade
---> Package gnutls-utils.x86_64 3.1.13-2.fc20 will be upgraded
---> Package gnutls-utils.x86_64 3.1.13-2.fc20 will be an upgrade
---> Package gpaste.x86_64 3.5-1.fc21 will be upgraded
---> Package gpaste.x86_64 3.5-1.fc21 will be an upgrade
---> Package gpaste-libs.x86_64 3.5-1.fc21 will be upgraded
---> Package gpaste-libs.x86_64 3.5-1.fc21 will be an upgrade
---> Package gupnp.x86_64 0.20.6-1.fc21 will be upgraded
---> Package gupnp.x86_64 0.20.6-1.fc21 will be an upgrade
---> Package gupnp-av.x86_64 0.12.2-2.fc20 will be upgraded
---> Package gupnp-av.x86_64 0.12.2-2.fc20 will be an upgrade
---> Package hostname.x86_64 3.14-2.fc21 will be upgraded
---> Package hostname.x86_64 3.14-2.fc21 will be an upgrade
---> Package initscripts.x86_64 9.50-1.fc21 will be upgraded
---> Package initscripts.x86_64 9.50-1.fc21 will be an upgrade
---> Package kernel-headers.x86_64 3.12.0-0.rc5.git1.1.fc21 will be upgraded
---> Package kernel-headers.x86_64 3.12.0-0.rc5.git1.1.fc21 will be an upgrade
---> Package kernel-modules-extra.x86_64 3.12.0-0.rc5.git1.1.fc21 will be upgraded
---> Package kernel-modules-extra.x86_64 3.12.0-0.rc5.git1.1.fc21 will be an upgrade
---> Package kernel-tools.x86_64 3.12.0-0.rc5.git1.1.fc21 will be upgraded
---> Package kernel-tools.x86_64 3.12.0-0.rc5.git1.1.fc21 will be an upgrade
---> Package kernel-tools-libs.x86_64 3.12.0-0.rc5.git1.1.fc21 will be upgraded
---> Package kernel-tools-libs.x86_64 3.12.0-0.rc5.git1.1.fc21 will be an upgrade
---> Package krb5-libs.x86_64 1.11.3-25.fc21 will be upgraded
---> Package krb5-libs.x86_64 1.11.3-25.fc21 will be an upgrade
---> Package krb5-pkinit.x86_64 1.11.3-25.fc21 will be upgraded
---> Package krb5-pkinit.x86_64 1.11.3-25.fc21 will be an upgrade
---> Package krb5-server.x86_64 1.11.3-25.fc21 will be upgraded
---> Package krb5-server.x86_64 1.11.3-25.fc21 will be an upgrade
---> Package krb5-workstation.x86_64 1.11.3-25.fc21 will be upgraded
---> Package krb5-workstation.x86_64 1.11.3-25.fc21 will be an upgrade
---> Package libgcj.x86_64 4.8.1-10.fc21 will be upgraded
---> Package libgcj.x86_64 4.8.1-10.fc21 will be an upgrade
---> Package libgfortran.x86_64 4.8.1-10.fc21 will be upgraded
---> Package libgfortran.x86_64 4.8.1-10.fc21 will be an upgrade
---> Package libquadmath.x86_64 4.8.1-10.fc21 will be upgraded
---> Package libquadmath.x86_64 4.8.1-10.fc21 will be an upgrade
---> Package libipa_hbac.x86_64 1.11.1-4.fc21 will be upgraded
---> Package libipa_hbac.x86_64 1.11.1-4.fc21 will be an upgrade
---> Package libipa_hbac-python.x86_64 1.11.1-4.fc21 will be upgraded
---> Package libipa_hbac-python.x86_64 1.11.1-4.fc21 will be an upgrade
---> Package libobjc.x86_64 4.8.1-10.fc21 will be upgraded
---> Package libobjc.x86_64 4.8.1-10.fc21 will be an upgrade
---> Package libsemanage.x86_64 2.1.10-13.fc21 will be upgraded
---> Package libsemanage.x86_64 2.1.10-13.fc21 will be an upgrade
---> Package libsemanage-python.x86_64 2.1.10-13.fc21 will be upgraded
---> Package libsemanage-python.x86_64 2.1.10-13.fc21 will be an upgrade
---> Package libsss_idmap.x86_64 1.11.1-4.fc21 will be upgraded
---> Package libsss_idmap.x86_64 1.11.1-4.fc21 will be an upgrade
---> Package libsss_nss_idmap.x86_64 1.11.1-4.fc21 will be upgraded
---> Package libsss_nss_idmap.x86_64 1.11.1-4.fc21 will be an upgrade
---> Package libstdc++.x86_64 4.8.1-10.fc21 will be upgraded
---> Package libstdc++.x86_64 4.8.1-10.fc21 will be an upgrade
---> Package libtar.x86_64 1.2.20-1.fc21 will be upgraded
---> Package libtar.x86_64 1.2.20-1.fc21 will be an upgrade
---> Package newt.x86_64 0.52.16-1.fc20 will be upgraded
---> Package newt.x86_64 0.52.16-1.fc20 will be an upgrade
---> Package newt-python.x86_64 0.52.16-1.fc20 will be upgraded
---> Package newt-python.x86_64 0.52.16-1.fc20 will be an upgrade
---> Package nmap.x86_64 2:6.40-2.fc20 will be upgraded
---> Package nmap.x86_64 2:6.40-2.fc20 will be an upgrade
---> Package nmap-ncat.x86_64 2:6.40-2.fc20 will be upgraded
---> Package nmap-ncat.x86_64 2:6.40-2.fc20 will be an upgrade
---> Package nmap-frontend.noarch 2:6.40-2.fc20 will be upgraded
---> Package nmap-frontend.noarch 2:6.40-2.fc20 will be an upgrade
---> Package openssl.x86_64 1:1.0.1e-27.fc21 will be upgraded
---> Package openssl.x86_64 1:1.0.1e-27.fc21 will be an upgrade
---> Package openssl-libs.x86_64 1:1.0.1e-27.fc21 will be upgraded
---> Package openssl-libs.x86_64 1:1.0.1e-27.fc21 will be an upgrade
---> Package pcre.x86_64 8.33-2.fc20.1 will be upgraded
---> Package pcre.x86_64 8.33-2.fc20.1 will be an upgrade
---> Package perl-ExtUtils-MakeMaker.noarch 6.78-1.fc21 will be upgraded
---> Package perl-ExtUtils-MakeMaker.noarch 6.78-1.fc21 will be an upgrade
---> Package perl-Net-Patricia.x86_64 1.21-1.fc21 will be upgraded
---> Package perl-Net-Patricia.x86_64 1.21-1.fc21 will be an upgrade
---> Package php.x86_64 5.5.4-1.fc21 will be upgraded
---> Package php.x86_64 5.5.4-1.fc21 will be an upgrade
---> Package php-cli.x86_64 5.5.4-1.fc21 will be upgraded
---> Package php-cli.x86_64 5.5.4-1.fc21 will be an upgrade
---> Package php-common.x86_64 5.5.4-1.fc21 will be upgraded
---> Package php-common.x86_64 5.5.4-1.fc21 will be an upgrade
---> Package php-gd.x86_64 5.5.4-1.fc21 will be upgraded
---> Package php-gd.x86_64 5.5.4-1.fc21 will be an upgrade
---> Package php-mbstring.x86_64 5.5.4-1.fc21 will be upgraded
---> Package php-mbstring.x86_64 5.5.4-1.fc21 will be an upgrade
---> Package php-mcrypt.x86_64 5.5.4-1.fc21 will be upgraded
---> Package php-mcrypt.x86_64 5.5.4-1.fc21 will be an upgrade
---> Package php-pdo.x86_64 5.5.4-1.fc21 will be upgraded
---> Package php-pdo.x86_64 5.5.4-1.fc21 will be an upgrade
---> Package php-process.x86_64 5.5.4-1.fc21 will be upgraded
---> Package php-process.x86_64 5.5.4-1.fc21 will be an upgrade
---> Package php-xml.x86_64 5.5.4-1.fc21 will be upgraded
---> Package php-xml.x86_64 5.5.4-1.fc21 will be an upgrade
---> Package policycoreutils.x86_64 2.1.14-86.fc21 will be upgraded
---> Package policycoreutils.x86_64 2.1.14-86.fc21 will be an upgrade
---> Package policycoreutils-devel.x86_64 2.1.14-86.fc21 will be upgraded
---> Package policycoreutils-devel.x86_64 2.1.14-86.fc21 will be an upgrade
---> Package policycoreutils-python.x86_64 2.1.14-86.fc21 will be upgraded
---> Package policycoreutils-python.x86_64 2.1.14-86.fc21 will be an upgrade
---> Package policycoreutils-restorecond.x86_64 2.1.14-86.fc21 will be upgraded
---> Package policycoreutils-restorecond.x86_64 2.1.14-86.fc21 will be an upgrade
---> Package policycoreutils-sandbox.x86_64 2.1.14-86.fc21 will be upgraded
---> Package policycoreutils-sandbox.x86_64 2.1.14-86.fc21 will be an upgrade
---> Package postgresql-libs.x86_64 9.3.1-1.fc21 will be upgraded
---> Package postgresql-libs.x86_64 9.3.1-1.fc21 will be an upgrade
---> Package sysvinit-tools.x86_64 2.88-14.dsf.fc21 will be obsolète
---> Package procps-ng.x86_64 3.3.8-15.fc21 will be upgraded
---> Package procps-ng.x86_64 3.3.8-15.fc21 will be an upgrade
---> Package python-sssdconfig.noarch 1.11.1-4.fc21 will be upgraded
---> Package python-sssdconfig.noarch 1.11.1-4.fc21 will be an upgrade
---> Package sane-backends.x86_64 1.0.24-1.fc21 will be upgraded
---> Package sane-backends.x86_64 1.0.24-1.fc21 will be an upgrade
---> Package sane-backends-drivers-scanners.x86_64 1.0.24-1.fc21 will be upgraded
---> Package sane-backends-drivers-scanners.x86_64 1.0.24-1.fc21 will be an upgrade
---> Package sane-backends-libs.x86_64 1.0.24-1.fc21 will be upgraded
---> Package sane-backends-libs.x86_64 1.0.24-1.fc21 will be an upgrade
---> Package selinux-policy.noarch 3.12.1-89.fc21 will be upgraded
---> Package selinux-policy.noarch 3.12.1-89.fc21 will be an upgrade
---> Package selinux-policy-targeted.noarch 3.12.1-89.fc21 will be upgraded
---> Package selinux-policy-targeted.noarch 3.12.1-89.fc21 will be an upgrade
---> Package selinux-policy-doc.noarch 3.12.1-89.fc21 will be upgraded
---> Package selinux-policy-doc.noarch 3.12.1-89.fc21 will be an upgrade
---> Package selinux-policy-devel.noarch 3.12.1-89.fc21 will be upgraded
---> Package selinux-policy-devel.noarch 3.12.1-89.fc21 will be an upgrade
---> Package sg3_utils-libs.x86_64 1.36-2.fc20 will be upgraded
---> Package sg3_utils-libs.x86_64 1.36-2.fc20 will be an upgrade
---> Package sip.x86_64 4.14.7-2.fc20 will be upgraded
---> Package sip.x86_64 4.14.7-2.fc20 will be an upgrade
---> Package sssd.x86_64 1.11.1-4.fc21 will be upgraded
---> Package sssd.x86_64 1.11.1-4.fc21 will be an upgrade
---> Package sssd-ad.x86_64 1.11.1-4.fc21 will be upgraded
---> Package sssd-ad.x86_64 1.11.1-4.fc21 will be an upgrade
---> Package sssd-client.x86_64 1.11.1-4.fc21 will be upgraded
---> Package sssd-client.x86_64 1.11.1-4.fc21 will be an upgrade
---> Package sssd-common.x86_64 1.11.1-4.fc21 will be upgraded
---> Package sssd-common.x86_64 1.11.1-4.fc21 will be an upgrade
---> Package sssd-common-pac.x86_64 1.11.1-4.fc21 will be upgraded
---> Package sssd-common-pac.x86_64 1.11.1-4.fc21 will be an upgrade
---> Package sssd-ipa.x86_64 1.11.1-4.fc21 will be upgraded
---> Package sssd-ipa.x86_64 1.11.1-4.fc21 will be an upgrade
---> Package sssd-krb5.x86_64 1.11.1-4.fc21 will be upgraded
---> Package sssd-krb5.x86_64 1.11.1-4.fc21 will be an upgrade
---> Package sssd-krb5-common.x86_64 1.11.1-4.fc21 will be upgraded
---> Package sssd-krb5-common.x86_64 1.11.1-4.fc21 will be an upgrade
---> Package sssd-ldap.x86_64 1.11.1-4.fc21 will be upgraded
---> Package sssd-ldap.x86_64 1.11.1-4.fc21 will be an upgrade
---> Package sssd-proxy.x86_64 1.11.1-4.fc21 will be upgraded
---> Package sssd-proxy.x86_64 1.11.1-4.fc21 will be an upgrade
---> Package sssd-tools.x86_64 1.11.1-4.fc21 will be upgraded
---> Package sssd-tools.x86_64 1.11.1-4.fc21 will be an upgrade
---> Package telepathy-salut.x86_64 0.8.1-3.fc20 will be upgraded
---> Package telepathy-salut.x86_64 0.8.1-3.fc20 will be an upgrade
---> Package zukitwo-common.noarch 20130424-2.fc20 will be upgraded
---> Package zukitwo-common.noarch 20130424-2.fc20 will be an upgrade
---> Package zukitwo-gtk3-theme.noarch 20130424-2.fc20 will be upgraded
---> Package zukitwo-gtk3-theme.noarch 20130424-2.fc20 will be an upgrade
--> Finished dependency resolution


Dependencies resolved.

================================================================================
 Package                          Architecture
                                         Version          Dépôt           Taille
================================================================================
Installation :
 kernel                           x86_64 3.12.0-0.rc5.git2.1.fc21
                                                          koji-f21-builds  32 M
Upgrading:
 atlas                            x86_64 3.10.1-7.fc21    koji-f21-builds 4.2 M
 autocorr-en                      noarch 1:4.1.3.1-1.fc21 koji-f21-builds 153 k
 autogen-libopts                  x86_64 5.18.2-1.fc21    koji-f21-builds  64 k
 avr-gcc                          x86_64 4.8.2-1.fc21     koji-f21-builds  10 M
 bluez                            x86_64 5.10-1.fc21      koji-f21-builds 901 k
 bluez-cups                       x86_64 5.10-1.fc21      koji-f21-builds  69 k
 bluez-libs                       x86_64 5.10-1.fc21      koji-f21-builds  66 k
 cpp                              x86_64 4.8.2-1.fc19     koji-f20-builds 5.9 M
 gcc                              x86_64 4.8.2-1.fc19     koji-f20-builds  16 M
 libgcc                           x86_64 4.8.2-1.fc19     koji-f20-builds  80 k
 libgomp                          x86_64 4.8.2-1.fc19     koji-f20-builds  98 k
 cups-filters                     x86_64 1.0.40-3.fc21    koji-f21-builds 366 k
 cups-filters-libs                x86_64 1.0.40-3.fc21    koji-f21-builds  94 k
 dom4j-manual                     noarch 1.6.1-19.fc21    koji-f21-builds 670 k
 eventlog                         x86_64 0.2.13-4.fc21    koji-f21-builds  18 k
 firefox                          x86_64 24.0-2.fc21      koji-f21-builds  27 M
 gnome-classic-session            noarch 3.10.1-1.fc21    koji-f21-builds  22 k
 gnome-shell-extension-alternate-tab
                                  noarch 3.10.1-1.fc21    koji-f21-builds  13 k
 gnome-shell-extension-apps-menu  noarch 3.10.1-1.fc21    koji-f21-builds  17 k
 gnome-shell-extension-auto-move-windows
                                  noarch 3.10.1-1.fc21    koji-f21-builds  16 k
 gnome-shell-extension-common     noarch 3.10.1-1.fc21    koji-f21-builds 101 k
 gnome-shell-extension-drive-menu noarch 3.10.1-1.fc21    koji-f21-builds  13 k
 gnome-shell-extension-launch-new-instance
                                  noarch 3.10.1-1.fc21    koji-f21-builds  12 k
 gnome-shell-extension-native-window-placement
                                  noarch 3.10.1-1.fc21    koji-f21-builds  18 k
 gnome-shell-extension-places-menu
                                  noarch 3.10.1-1.fc21    koji-f21-builds  16 k
 gnome-shell-extension-systemMonitor
                                  noarch 3.10.1-1.fc21    koji-f21-builds  15 k
 gnome-shell-extension-user-theme noarch 3.10.1-1.fc21    koji-f21-builds  13 k
 gnome-shell-extension-window-list
                                  noarch 3.10.1-1.fc21    koji-f21-builds  20 k
 gnome-shell-extension-windowsNavigator
                                  noarch 3.10.1-1.fc21    koji-f21-builds  14 k
 gnome-shell-extension-workspace-indicator
                                  noarch 3.10.1-1.fc21    koji-f21-builds  14 k
 gnome-shell-theme-zukitwo        noarch 20131012-1.fc21  koji-f21-builds 149 k
 gnutls                           x86_64 3.1.13-3.fc21    koji-f21-builds 602 k
 gnutls-dane                      x86_64 3.1.13-3.fc21    koji-f21-builds  48 k
 gnutls-utils                     x86_64 3.1.13-3.fc21    koji-f21-builds 265 k
 gpaste                           x86_64 3.6-1.fc21       koji-f21-builds  59 k
 gpaste-libs                      x86_64 3.6-1.fc21       koji-f21-builds  63 k
 gupnp                            x86_64 0.20.7-1.fc21    koji-f21-builds  91 k
 gupnp-av                         x86_64 0.12.3-1.fc21    koji-f21-builds  86 k
 hostname                         x86_64 3.14-3.fc21      koji-f21-builds  16 k
 initscripts                      x86_64 9.50-2.fc21      koji-f21-builds 413 k
 kernel-headers                   x86_64 3.12.0-0.rc5.git2.1.fc21
                                                          koji-f21-builds 910 k
 kernel-modules-extra             x86_64 3.12.0-0.rc5.git2.1.fc21
                                                          koji-f21-builds 2.1 M
 kernel-tools                     x86_64 3.12.0-0.rc5.git2.1.fc21
                                                          koji-f21-builds 117 k
 kernel-tools-libs                x86_64 3.12.0-0.rc5.git2.1.fc21
                                                          koji-f21-builds  57 k
 krb5-libs                        x86_64 1.11.3-26.fc21   koji-f21-builds 799 k
 krb5-pkinit                      x86_64 1.11.3-26.fc21   koji-f21-builds 130 k
 krb5-server                      x86_64 1.11.3-26.fc21   koji-f21-builds 870 k
 krb5-workstation                 x86_64 1.11.3-26.fc21   koji-f21-builds 716 k
 libgcj                           x86_64 4.8.2-1.fc19     koji-f20-builds  18 M
 libgfortran                      x86_64 4.8.2-1.fc19     koji-f20-builds 275 k
 libquadmath                      x86_64 4.8.2-1.fc19     koji-f20-builds 168 k
 libipa_hbac                      x86_64 1.11.1-5.fc21    koji-f21-builds  59 k
 libipa_hbac-python               x86_64 1.11.1-5.fc21    koji-f21-builds  54 k
 libobjc                          x86_64 4.8.2-1.fc19     koji-f20-builds  58 k
 libsemanage                      x86_64 2.1.10-14.fc21   koji-f21-builds 120 k
 libsemanage-python               x86_64 2.1.10-14.fc21   koji-f21-builds  93 k
 libsss_idmap                     x86_64 1.11.1-5.fc21    koji-f21-builds  63 k
 libsss_nss_idmap                 x86_64 1.11.1-5.fc21    koji-f21-builds  62 k
 libstdc++                        x86_64 4.8.2-1.fc19     koji-f20-builds 280 k
 libtar                           x86_64 1.2.20-2.fc21    koji-f21-builds  33 k
 newt                             x86_64 0.52.16-2.fc21   koji-f21-builds 104 k
 newt-python                      x86_64 0.52.16-2.fc21   koji-f21-builds  53 k
 nmap                             x86_64 2:6.40-3.fc21    koji-f21-builds 3.9 M
 nmap-ncat                        x86_64 2:6.40-3.fc21    koji-f21-builds 121 k
 nmap-frontend                    noarch 2:6.40-3.fc21    koji-f21-builds 658 k
 openssl                          x86_64 1:1.0.1e-28.fc21 koji-f21-builds 702 k
 openssl-libs                     x86_64 1:1.0.1e-28.fc21 koji-f21-builds 907 k
 pcre                             x86_64 8.33-3.fc21      koji-f21-builds 439 k
 perl-ExtUtils-MakeMaker          noarch 6.80-1.fc21      koji-f21-builds 281 k
 perl-Net-Patricia                x86_64 1.22-1.fc21      koji-f21-builds  41 k
 php                              x86_64 5.5.5-1.fc21     koji-f21-builds 2.6 M
 php-cli                          x86_64 5.5.5-1.fc21     koji-f21-builds 2.6 M
 php-common                       x86_64 5.5.5-1.fc21     koji-f21-builds 1.0 M
 php-gd                           x86_64 5.5.5-1.fc21     koji-f21-builds  83 k
 php-mbstring                     x86_64 5.5.5-1.fc21     koji-f21-builds 564 k
 php-mcrypt                       x86_64 5.5.5-1.fc21     koji-f21-builds  52 k
 php-pdo                          x86_64 5.5.5-1.fc21     koji-f21-builds 136 k
 php-process                      x86_64 5.5.5-1.fc21     koji-f21-builds  72 k
 php-xml                          x86_64 5.5.5-1.fc21     koji-f21-builds 240 k
 policycoreutils                  x86_64 2.1.14-88.fc21   koji-f21-builds 782 k
 policycoreutils-devel            x86_64 2.1.14-88.fc21   koji-f21-builds 253 k
 policycoreutils-python           x86_64 2.1.14-88.fc21   koji-f21-builds 1.8 M
 policycoreutils-restorecond      x86_64 2.1.14-88.fc21   koji-f21-builds 161 k
 policycoreutils-sandbox          x86_64 2.1.14-88.fc21   koji-f21-builds 158 k
 postgresql-libs                  x86_64 9.3.1-2.fc21     koji-f21-builds 227 k
 sysvinit-tools                   x86_64 2.88-14.dsf.fc21 @System          58 k
     remplacement de  sysvinit-tools.x86_64 2.88-14.dsf.fc21
 python-sssdconfig                noarch 1.11.1-5.fc21    koji-f21-builds  84 k
 sane-backends                    x86_64 1.0.24-2.fc21    koji-f21-builds 665 k
 sane-backends-drivers-scanners   x86_64 1.0.24-2.fc21    koji-f21-builds 2.2 M
 sane-backends-libs               x86_64 1.0.24-2.fc21    koji-f21-builds  92 k
 selinux-policy                   noarch 3.12.1-91.fc21   koji-f21-builds 296 k
 selinux-policy-targeted          noarch 3.12.1-91.fc21   koji-f21-builds 3.5 M
 selinux-policy-doc               noarch 3.12.1-91.fc21   koji-f21-builds 800 k
 selinux-policy-devel             noarch 3.12.1-91.fc21   koji-f21-builds 3.0 M
 sg3_utils-libs                   x86_64 1.37-1.fc21      koji-f21-builds  61 k
 sip                              x86_64 4.15.3-1.fc21    koji-f21-builds 119 k
 sssd                             x86_64 1.11.1-5.fc21    koji-f21-builds  53 k
 sssd-ad                          x86_64 1.11.1-5.fc21    koji-f21-builds 138 k
 sssd-client                      x86_64 1.11.1-5.fc21    koji-f21-builds 110 k
 sssd-common                      x86_64 1.11.1-5.fc21    koji-f21-builds 1.1 M
 sssd-common-pac                  x86_64 1.11.1-5.fc21    koji-f21-builds 108 k
 sssd-ipa                         x86_64 1.11.1-5.fc21    koji-f21-builds 248 k
 sssd-krb5                        x86_64 1.11.1-5.fc21    koji-f21-builds  97 k
 sssd-krb5-common                 x86_64 1.11.1-5.fc21    koji-f21-builds 189 k
 sssd-ldap                        x86_64 1.11.1-5.fc21    koji-f21-builds 189 k
 sssd-proxy                       x86_64 1.11.1-5.fc21    koji-f21-builds 104 k
 sssd-tools                       x86_64 1.11.1-5.fc21    koji-f21-builds 329 k
 telepathy-salut                  x86_64 0.8.1-5.fc21     koji-f21-builds 390 k
 zukitwo-common                   noarch 20131012-1.fc21  koji-f21-builds  18 k
 zukitwo-gtk3-theme               noarch 20131012-1.fc21  koji-f21-builds  58 k

Résumé de la transaction
================================================================================
Installation     1 Paquet
Mettre à jour  110 Paquets

Taille totale des téléchargements : 156 M
Téléchargement des paquets :
Traceback (most recent call last):
  File "/usr/bin/dnf", line 35, in <module>
    main.user_main(sys.argv[1:], exit_code=True)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 272, in user_main
    errcode = main(args)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 64, in main
    return _main(base, args)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 187, in _main
    return_code, resultmsgs = base.do_transaction()
  File "/usr/lib/python2.7/site-packages/dnf/cli/cli.py", line 185, in do_transaction
    self.download_callback_total_cb)
  File "/usr/lib/python2.7/site-packages/dnf/yum/base.py", line 1024, in download_packages
    remote_pkgs = filter(lambda po: not (po.from_cmdline or po.repo.local), pkglist)
  File "/usr/lib/python2.7/site-packages/dnf/yum/base.py", line 1024, in <lambda>
    remote_pkgs = filter(lambda po: not (po.from_cmdline or po.repo.local), pkglist)
  File "/usr/lib/python2.7/site-packages/dnf/package.py", line 109, in repo
    return self.yumbase.repos[self.reponame]
KeyError: '@System'


dnf-0.4.4-1.fc21.noarch
Comment 1 Michal Schmidt 2013-10-19 13:45:34 EDT
Looks like the same issue as bug 1021087.
Comment 2 Ales Kozumplik 2013-10-20 01:52:51 EDT
Indeed, this is a dupe. Thank you for reporting anyway, Nicolas.

*** This bug has been marked as a duplicate of bug 1021087 ***

Note You need to log in before you can comment on or make changes to this bug.