Bug 1021110 - u-boot.imx does not start extlinux automatically
u-boot.imx does not start extlinux automatically
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: uboot-tools (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Dennis Gilmore
Fedora Extras Quality Assurance
RejectedBlocker AcceptedFreezeException
: Patch
Depends On:
Blocks: ARMTracker F20BetaFreezeException
  Show dependency treegraph
 
Reported: 2013-10-19 09:25 EDT by Niels de Vos
Modified: 2013-10-22 01:39 EDT (History)
5 users (show)

See Also:
Fixed In Version: uboot-tools-2013.10-2.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-22 01:39:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Add a default menu to u-boot, which executes the default 'bootcmd' command/script (738 bytes, patch)
2013-10-19 09:25 EDT, Niels de Vos
no flags Details | Diff

  None (edit)
Description Niels de Vos 2013-10-19 09:25:17 EDT
Created attachment 813990 [details]
Add a default menu to u-boot, which executes the default 'bootcmd' command/script

Description of problem:
On my Wandboard DualLite the u-boot.imx version shows a menu and enters the commandline after a short timeout. It is needed to execute the 'boot' command to start extlinux which shows the selection of kernels installed.

Version-Release number of selected component (if applicable):
uboot-wandboard_dl-2013.10-0.5.rc4.fc20.armv7hl

How reproducible:
100%

Steps to Reproduce:
1. dd the u-boot.imx to the sd-card
   # dd if=/usr/share/uboot-imx6dl/u-boot.imx of=/dev/mmcblk0 bs=512 seek=2
2. boot from the sd-card

Actual results:
U-boot enters the commandline and waits for user input.

Expected results:
U-boot starts extlinux, which boots the kernel after a timeout.

Additional info:
* I've tested the attached patch, and this works fine for me.
* The default bootcmd has been patched in the Fedora package, there is no
  patch in upstream needed.
* This might be an issue on other boards as well, but I am not able to test
  that.
Comment 1 Fedora Update System 2013-10-20 16:53:06 EDT
uboot-tools-2013.10-2.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/uboot-tools-2013.10-2.fc20
Comment 2 Dennis Gilmore 2013-10-20 19:13:06 EDT
Proposing as a blocker as i think it makes for a better user experience and violates the the following criteria, 

Expected installed system boot behavior

A system installed without a graphical package set must boot to a working login prompt without any unintended user intervention, and all virtual consoles intended to provide a working login prompt must do so.
Comment 3 Adam Williamson 2013-10-21 10:15:39 EDT
According to https://fedoraproject.org/wiki/Architectures/ARM/Supported_Platforms :

"Wandboard 	yes 	Quad works, dual and solo untested"

kinda doesn't gel with considering bugs in DualLite to be blockers?
Comment 4 Mike Ruckman 2013-10-21 12:57:15 EDT
Discussed this in 2013-10-21 Blocker Review Meeting [1]. Rejected as a blocker issue as it does not appear to be serious enough to merit that status, but accepted as a freeze exception issue as it will improve the experience on wandboard systems and looks to be a safe fix

[1] http://meetbot.fedoraproject.org/fedora-blocker-review/2013-10-21/
Comment 5 Fedora Update System 2013-10-22 01:39:54 EDT
uboot-tools-2013.10-2.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.