Bug 1021118 - pavucontrol is segfaulting in rawhide
pavucontrol is segfaulting in rawhide
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: pavucontrol (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-19 11:09 EDT by Bruno Wolff III
Modified: 2013-10-23 19:03 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-23 19:03:48 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bruno Wolff III 2013-10-19 11:09:49 EDT
Description of problem:
pavucontrol segfaults when run. This makes it hard to change settings for sound devices.

I am running an xfce desktop.

Version-Release number of selected component (if applicable):
pavucontrol-2.0-2.fc20.i686

How reproducible:
100%

Steps to Reproduce:
If you want to see the segfault message you can run pavucontrol from a shell prompt. If you run it normally you just see a window open briefly and then close.

Actual results:

bash-4.2$ gdb `which pavucontrol`
GNU gdb (GDB) Fedora 7.6.50.20130731-12.fc21
Copyright (C) 2013 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "i686-redhat-linux-gnu".
Type "show configuration" for configuration details.
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>.
Find the GDB manual and other documentation resources online at:
<http://www.gnu.org/software/gdb/documentation/>.
For help, type "help".
Type "apropos word" to search for commands related to "word".
..
Reading symbols from /usr/bin/pavucontrol...Reading symbols from /usr/bin/pavucontrol...(no debugging symbols found)...done.
(no debugging symbols found)...done.
Missing separate debuginfos, use: debuginfo-install pavucontrol-2.0-2.fc20.i686
(gdb) run
Starting program: /usr/bin/pavucontrol 
Traceback (most recent call last):
  File "/usr/share/gdb/auto-load/usr/lib/libgobject-2.0.so.0.3800.0-gdb.py", line 9, in <module>
    from gobject import register
  File "/usr/share/glib-2.0/gdb/gobject.py", line 3, in <module>
    import gdb.backtrace
ImportError: No module named backtrace
Traceback (most recent call last):
  File "/usr/share/gdb/auto-load/usr/lib/libgobject-2.0.so.0.3800.0-gdb.py", line 9, in <module>
    from gobject import register
  File "/usr/share/glib-2.0/gdb/gobject.py", line 3, in <module>
    import gdb.backtrace
ImportError: No module named backtrace
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/libthread_db.so.1".
[New Thread 0xb7ba5b40 (LWP 20320)]

Program received signal SIGSEGV, Segmentation fault.
0x4b7af261 in __strlen_ia32 () from /lib/libc.so.6
(gdb)
Comment 1 Julian Sikorski 2013-10-20 12:41:43 EDT

*** This bug has been marked as a duplicate of bug 972351 ***
Comment 2 Bruno Wolff III 2013-10-22 09:56:44 EDT
I don't think this is really a duplicate of bug 972351. pavucontrol is segfaulting and I was just running gdb to try to provide more information about the pavucontrol problem. It looks like bug 972351 might be affecting the output of gdb, but that's a separate problem.
The pavucontrol issue makes it hard to set up your sound devices. (I'm guessing there is a way to modify the config directly, but I haven't found it yet.)
Comment 3 Bruno Wolff III 2013-10-23 11:08:36 EDT
I tried rebuilding pavucontrol locally and that fixed my issue. So my first guess is that some library in rawhide had an abi change without a soname bump. I'll do a rebuild of pavucontrol in rawhide sometime today, so that it will show up in tomorrow's compose.
Comment 4 Bruno Wolff III 2013-10-23 19:03:48 EDT
pavucontrol-2.0-3.fc21.i686 seems to fix the problem, so I am closing this.

Note You need to log in before you can comment on or make changes to this bug.