Bug 1021126 - Package/Component names and descriptions should reflect function
Package/Component names and descriptions should reflect function
Status: CLOSED CURRENTRELEASE
Product: JBoss Fuse Service Works 6
Classification: JBoss
Component: Installer (Show other bugs)
6.0.0 GA
Unspecified Unspecified
unspecified Severity high
: ER7
: 6.0.0
Assigned To: Thomas Hauser
Len DiMaggio
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-19 12:28 EDT by Catherine Robson
Modified: 2014-02-06 10:33 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
New text (122.17 KB, image/png)
2013-10-22 17:18 EDT, Thomas Hauser
no flags Details

  None (edit)
Description Catherine Robson 2013-10-19 12:28:57 EDT
Description of problem:
The package names listed in the installer are acronyms of the components as Red Hat has named those components rather than user-undertandable names of what those components do.  The descriptions of these components also do not give any further information today.

Version-Release number of selected component (if applicable):
6.0.0.ER5

How reproducible:
Run installer -> Select pack you would like to install screen

Suggested names and descriptions (should be reviewed and agreed on for acurracy):
Current and suggested name: Red Hat JBoss Enterprise Application Platform
Suggested description:  Application platform that will host Red Hat JBoss Fuse Service Works capabilities.

Current and suggested name:  Red Hat JBoss Fuse Service Works
Suggested description: Configuration changes to Red Hat JBoss Enterprise Application Platform which will enable Fuse Service Works capabilities.

Current name: RT-Gov Client-only   Suggested Name: Run-Time Governance Client
Suggested description: Contains the files that will enable run-time governance on this local machine so it can monitor a server installed elsewhere.  Cannot be selected if you have chosen Run-Time Governance Server and Client.

Current name: RT-Gov Server+Client  Suggested Name: Run-Time Governance Server and Client
Suggested description: Contains the files that will enable governance to monitor, control, audit, and apply policy enforcement to the services at run-time.

Current name: DT-Gov run-time  Suggested name:  Design-Time Governance
Suggested Description: Design-Time Governance provides support for design, creation, and implementation of services. In addition to that, it also supports service testing, deployment, and versioning.

Current name: S-RAMP run-time  Suggested name:  S-RAMP Repository
Suggested description: The S-RAMP Repository is a central repository for storing for services and their constituent files, including policies and documentation.

Current and Suggested name: Red Hat JBoss Fuse Service Works quickstarts
Suggested description: These quickstarts will allow you to set up an already running project where you can utilize working code to build from for your projects.

Current name: RTGov Server quickstarts  Suggested name:  Run-Time Governance quickstarts
Suggested description: ??

Current name: DTGov quickstarts   Suggested name: Design-Time Governance quickstarts
Suggested description: ??

Current name: S-RAMP quickstarts   Suggested name: S-RAMP Repository quickstarts
Suggested description: ??
Comment 2 Catherine Robson 2013-10-19 13:00:18 EDT
The description of EAP should also include the major and minor version so the users know what they are installing.
Comment 3 Thomas Hauser 2013-10-22 17:13:44 EDT
A mechanism is in place to easily add any text desired. Attached is the result of the changes I've made so far. When the strings are final they can be added in with minimal effort / time.
Comment 4 Thomas Hauser 2013-10-22 17:18:08 EDT
Created attachment 815183 [details]
New text
Comment 5 Thomas Hauser 2013-11-05 10:07:28 EST
Since no comments are forthcoming I am marking this bug as MODIFIED.
Comment 6 Len DiMaggio 2013-12-16 14:31:09 EST
Verified in ER7-2

Note You need to log in before you can comment on or make changes to this bug.