Bug 1021142 - devscripts 2.13.4-3 not built with $RPM_{OPT,LD}_FLAGS
devscripts 2.13.4-3 not built with $RPM_{OPT,LD}_FLAGS
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: devscripts (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Sandro Mani
Fedora Extras Quality Assurance
:
Depends On:
Blocks: DebugInfo
  Show dependency treegraph
 
Reported: 2013-10-19 15:24 EDT by Ville Skyttä
Modified: 2013-11-10 02:47 EST (History)
2 users (show)

See Also:
Fixed In Version: devscripts-2.13.4-4.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-10 01:19:26 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ville Skyttä 2013-10-19 15:24:06 EDT
devscripts 2.13.4-3 is not built with $RPM_{OPT,LD}_FLAGS, see the cc lines in the build log. Also, scripts/Makefile uses dpkg-buildflags to get CFLAGS and LDFLAGS so maybe a build dep on dpkg-dev should be added.
Comment 1 Sandro Mani 2013-10-19 16:24:02 EDT
Thanks for catching this. dpkg-buildflags --get CFLAGS does not return %{optflags}, so I added CFLAGS="%{optflags}" to the makefile.
Comment 2 Fedora Update System 2013-10-19 18:11:55 EDT
devscripts-2.13.4-4.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/devscripts-2.13.4-4.fc20
Comment 3 Ville Skyttä 2013-10-20 03:17:24 EDT
It's still not being built with $RPM_LD_FLAGS, but that's a minor issue since the Fedora ld defaults are effectively the same. I'd fix it anyway.
Comment 4 Sandro Mani 2013-10-20 05:57:46 EDT
What is the macro for $RPM_LD_FLAGS, or does no such macro exist? Btw: since I'm going to rebuild again, I'm going to add Obsoletes: rpmdevtools < 8.4, can you do it as well in rpmdevtools?
Comment 5 Ville Skyttä 2013-10-20 06:13:12 EDT
I suppose some kind of an kldugy macro version of $RPM_LD_FLAGS exists, but I don't remember it and would just use the shell var.

Wrt the devscripts<->rpmdevtools stuff, I'm done with it and will leave rpmdevtools 8.4-2 as it is now, I don't have any more time or interest for that hackery.
Comment 6 Sandro Mani 2013-10-20 06:21:17 EDT
Ok, fair enough. Thanks for you patience.
Comment 7 Fedora Update System 2013-10-20 07:19:41 EDT
devscripts-2.13.4-5.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/devscripts-2.13.4-5.fc20
Comment 8 Fedora Update System 2013-10-20 13:46:39 EDT
Package devscripts-2.13.4-5.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing devscripts-2.13.4-5.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-19555/devscripts-2.13.4-5.fc20
then log in and leave karma (feedback).
Comment 9 Igor Gnatenko 2013-10-21 05:26:56 EDT
Why not:
%prep
echo '#!/bin/sh' > ./configure
chmod +x ./configure

%build
%configure

?


http://pkgs.fedoraproject.org/cgit/gmqcc.git/tree/gmqcc.spec
Comment 10 Ville Skyttä 2013-10-21 05:33:49 EDT
Heh, that's a clever hack :). One could "clean it up" even a bit more by just forgetting about the %prep stuff altogether and doing something like this instead:

    %build
    %configure 2>/dev/null || : # just for setting *FLAGS

But I suppose it wouldn't work for this package as IIRC it doesn't honor *FLAGS from the environment, they need to be passed as arguments to make.
Comment 11 Sandro Mani 2013-10-21 08:09:14 EDT
Correct, it does not work.
Comment 12 Fedora Update System 2013-11-10 01:19:26 EST
devscripts-2.13.4-5.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 13 Fedora Update System 2013-11-10 02:47:17 EST
devscripts-2.13.4-4.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.