Bug 1021158 - [abrt] dnf-0.4.4-1.fc20: package.py:109:repo:KeyError: '@System'
[abrt] dnf-0.4.4-1.fc20: package.py:109:repo:KeyError: '@System'
Status: CLOSED DUPLICATE of bug 1021087
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
rawhide
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
abrt_hash:806f0207082a02a71c789a426ee...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-19 19:42 EDT by menzinoah
Modified: 2013-10-20 01:53 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-20 01:53:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (1.21 KB, text/plain)
2013-10-19 19:42 EDT, menzinoah
no flags Details
File: environ (2.15 KB, text/plain)
2013-10-19 19:42 EDT, menzinoah
no flags Details

  None (edit)
Description menzinoah 2013-10-19 19:42:43 EDT
Description of problem:
I executed 'sudo dnf update'

Version-Release number of selected component:
dnf-0.4.4-1.fc20

Additional info:
reporter:       libreport-2.1.8
cmdline:        /usr/bin/python /bin/dnf update
executable:     /bin/dnf
kernel:         3.11.5-300.fc20.x86_64
runlevel:       N 5
type:           Python
uid:            0

Truncated backtrace:
package.py:109:repo:KeyError: '@System'

Traceback (most recent call last):
  File "/bin/dnf", line 35, in <module>
    main.user_main(sys.argv[1:], exit_code=True)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 272, in user_main
    errcode = main(args)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 64, in main
    return _main(base, args)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 187, in _main
    return_code, resultmsgs = base.do_transaction()
  File "/usr/lib/python2.7/site-packages/dnf/cli/cli.py", line 185, in do_transaction
    self.download_callback_total_cb)
  File "/usr/lib/python2.7/site-packages/dnf/yum/base.py", line 1024, in download_packages
    remote_pkgs = filter(lambda po: not (po.from_cmdline or po.repo.local), pkglist)
  File "/usr/lib/python2.7/site-packages/dnf/yum/base.py", line 1024, in <lambda>
    remote_pkgs = filter(lambda po: not (po.from_cmdline or po.repo.local), pkglist)
  File "/usr/lib/python2.7/site-packages/dnf/package.py", line 109, in repo
    return self.yumbase.repos[self.reponame]
KeyError: '@System'

Local variables in innermost frame:
self: <hawkey.Package object id 2358, sysvinit-tools-2.88-14.dsf.fc20.x86_64, @System>
Comment 1 menzinoah 2013-10-19 19:42:48 EDT
Created attachment 814124 [details]
File: backtrace
Comment 2 menzinoah 2013-10-19 19:42:51 EDT
Created attachment 814125 [details]
File: environ
Comment 3 Ales Kozumplik 2013-10-20 01:53:36 EDT
Hello, this is a duplicate of bug 1021087.

*** This bug has been marked as a duplicate of bug 1021087 ***

Note You need to log in before you can comment on or make changes to this bug.