Bug 1021187 - dependency issue in fedfs-utils-devel
dependency issue in fedfs-utils-devel
Status: CLOSED ERRATA
Product: Fedora EPEL
Classification: Fedora
Component: fedfs-utils (Show other bugs)
el6
Unspecified Unspecified
unspecified Severity urgent
: ---
: ---
Assigned To: Ian Kent
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-20 04:43 EDT by Tuomo Soini
Modified: 2013-11-06 13:26 EST (History)
3 users (show)

See Also:
Fixed In Version: fedfs-utils-0.9.4-2.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-06 13:26:05 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tuomo Soini 2013-10-20 04:43:24 EDT
package: fedfs-utils-devel-0.9.4-1.el6.x86_64 from epel-testing
  unresolved deps: 
     fedfs-utils-lib(x86-64) = 0:0.9.4-1.el6


fedfs-utils-lib is not build on epel6 but lastest build add fedfs-utils-devel which has hardcoded dependency on fedfs-utils-lib%{?_isa}
Comment 1 Chuck Lever 2013-10-20 11:31:28 EDT
I copied the -devel subpackage definition from the Fedora version of fedfs-utils.  Fedora has -lib.

I'm not sure why a -lib dependency is needed for -devel.  Having the C include file in this package simply enables junction resolution support when mountd (nfs-utils) is built.  A mountd built with junction support will simply ignore junctions if the fedfs-utils-lib subpackage is not installed, that is expected and correct behavior.

Though -lib requires kernel support to actually work, the plug-in will install and mountd can load it without kernel changes.  We will eventually need -lib anyway, so I will see about adding that subpackage to resolve this bugzilla.
Comment 2 Fedora Update System 2013-10-20 12:54:13 EDT
fedfs-utils-0.9.4-2.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/fedfs-utils-0.9.4-2.el6
Comment 3 Tuomo Soini 2013-10-20 13:55:27 EDT
That build won't help much because of:

package: fedfs-utils-lib-0.9.4-2.el6.x86_64
  unresolved deps: 
     fedfs-utils-nsdbparams(x86-64) = 0:0.9.4-2.el6
Comment 4 Tuomo Soini 2013-10-20 14:00:31 EDT
Ignore previous - that package was missing from my testing environment.
Comment 5 Fedora Update System 2013-10-21 12:44:11 EDT
Package fedfs-utils-0.9.4-2.el6:
* should fix your issue,
* was pushed to the Fedora EPEL 6 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing fedfs-utils-0.9.4-2.el6'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2013-11909/fedfs-utils-0.9.4-2.el6
then log in and leave karma (feedback).
Comment 6 Fedora Update System 2013-11-06 13:26:05 EST
fedfs-utils-0.9.4-2.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.