Bug 1021196 - system-config-keyboard not being called to reset keyboard
system-config-keyboard not being called to reset keyboard
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: systemd (Show other bugs)
rawhide
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: systemd-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-20 06:00 EDT by Leslie Satenstein
Modified: 2013-12-30 02:40 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-29 20:12:04 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Leslie Satenstein 2013-10-20 06:00:55 EDT
Description of problem:
During Anaconda setup.
Step 1  Select English as the installation language.
Step 2  Select Canadian French as the only Keyboard in the system.

When I boot the system, the "virtual terminal (ctl-alt-f2...ctl-alt-f6)" default keyboard layout and keymapping remains unchanged as English USA.

If there is only 1 keyboard type on the system, the default terminal keyboard selection should follow the order of the settings selected in Anaconda keyboard selection.

Version-Release number of selected component (if applicable):

F20-Beta-TC5

How reproducible:


Install F30-Beta-TC5.

Steps to Reproduce:
1.
2.
3.

Actual results:

(Virtual) keyboard layout does not follow the resetting of the reassigned keyboard setup. 

Expected results:

Expect Keyboard setup to follow the defined primary Keyboard selection.

Additional info:

Anaconda worked correctly in F20-Alpha-TC5.  

Keyboard mapping for virtual terminal was corrected with 

system-config-keyboard function.
Comment 1 Peter Hutterer 2013-10-20 20:43:10 EDT
fedora-setup-keyboard doesn't exist anymore, it's been replaced by systemd-localed

do you have a /etc/X11/xorg.conf.d/00-keyboard.conf?
Comment 2 Leslie Satenstein 2013-10-21 07:32:44 EDT
There was no 00-keyboard.conf prior to my executing the system-config-keyboard.

I searched all of X11 and also /usr/share/X11/xorg.conf.d for the keyboard definition.

I have three systems with F20, and the problem was apparent on the three.
Comment 3 Need Real Name 2013-12-29 18:45:47 EST
s-c-k needs to update vconsole.keymap=XX in /etc/default/grub
Comment 4 Leslie Satenstein 2013-12-29 20:12:04 EST
With the correction of other keyboard issues for non-english languages, this issue became part of the corrective.

Therefore, it is no longer an issue,
Comment 5 Need Real Name 2013-12-30 02:40:49 EST
Really? If I boot with vconsole.keymap=de in /etc/default/grub and re-generate my grub config, then run s-c-k it doesn't update. I have the wrong keyboard map.

Note You need to log in before you can comment on or make changes to this bug.