Bug 1021219 - Glance cannot communicate with Qpid
Glance cannot communicate with Qpid
Status: CLOSED DUPLICATE of bug 1020025
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-glance (Show other bugs)
4.0
Unspecified Linux
unspecified Severity urgent
: beta
: 4.0
Assigned To: Flavio Percoco
Haim
storage
: TestBlocker
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-20 07:34 EDT by Nir Magnezi
Modified: 2016-04-26 12:28 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-24 09:11:50 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nir Magnezi 2013-10-20 07:34:04 EDT
Description of problem:
=======================
Via packstack, I installed Glance as a standalone node.
It fails to communicate with QPID and as a result - image upload fails. 

Version-Release number of selected component (if applicable):
=============================================================
puddle: 2013-10-15.1

python-glanceclient-0.10.0-1.el6ost.noarch
openstack-glance-2013.2-0.12.rc1.el6ost.noarch
python-glance-2013.2-0.12.rc1.el6ost.noarch

How reproducible:
=================
Always

Steps to Reproduce:
===================
1. Install OpenStack via packstack, Make sure that the node you configure to run Glance is only used with  CONFIG_GLANCE_HOST.
2. Via CLI, try to upload an image to glance.
3. Check Glance logs

Actual results:
===============
Image status stuck at status: queued

glance api log:
2013-10-20 10:19:48.716 6791 WARNING qpid.messaging [-] recoverable error[attempt 1927]: [Errno 111] ECONNREFUSED
2013-10-20 10:19:48.717 6791 WARNING qpid.messaging [-] sleeping 120 seconds
2013-10-20 10:21:48.719 6791 WARNING qpid.messaging [-] trying: localhost:5672

glance registry log:

2013-10-17 12:21:16.769 23433 WARNING keystoneclient.middleware.auth_token [-] Configuring auth_uri to point to the public identity endpoint is required; clients may not be able to authenticate against an admin endpoint

Expected results:
=================
Glance should be able to communicate with Qpid.
image upload should work OK.

Additional Info:
================
qpid client ver: python-qpid-0.14-11.el6_3.noarch
Comment 3 Flavio Percoco 2013-10-24 09:11:50 EDT
This bug is related to #1020025, the issue is that the right config parameter is qpid_hostname and not qpid_host.

*** This bug has been marked as a duplicate of bug 1020025 ***

Note You need to log in before you can comment on or make changes to this bug.