This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1021224 - remove the message to reboot host after packstack on rhel6.5
remove the message to reboot host after packstack on rhel6.5
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-packstack (Show other bugs)
4.0
Unspecified Unspecified
high Severity low
: rc
: 4.0
Assigned To: Martin Magr
Ofer Blaut
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-20 09:23 EDT by Ofer Blaut
Modified: 2016-04-26 14:05 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Previously, Packstack prompted always users to reboot the host after installing any OpenStack services, even when a new kernel package was not installed. This update fixes the issue, ensuring that Packstack only prompts users to reboot if a new kernel package is installed and needs to be loaded.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-19 19:29:57 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ofer Blaut 2013-10-20 09:23:20 EDT
Description of problem:

While new kernel for namespace is needed in rhel 6.4 followed by hosts reboot, in rhel 6.5 it is not needed since kernel support namespace.


We need to remove the following message from packstack when using rhel 6.5 


"Kernel package with netns support has been installed on host 10.35.160.19. Because of the kernel update the host mentioned above requires reboot "

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.install neutron with packstack on rhel 6.5
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Alvaro Lopez Ortega 2013-11-15 07:49:39 EST
According to Martin this was fixed already. Now the message is only displayed when the new kernel has been installed.
Comment 3 Scott Lewis 2013-11-19 11:54:30 EST
Auto adding >= MODIFIED bugs to beta
Comment 6 Alvaro Lopez Ortega 2013-12-05 13:49:32 EST
Ofer, could you please reproduce it again and provide us the packstack and puppet logs to make sure the kernel wasn't actually installed. If it were installed, this wouldn't actually be a bug.
Comment 7 Martin Magr 2013-12-06 08:24:53 EST
Ofer,

note that the reboot message is not still there for one use-case:
Kernel was updated but was not loaded, eg. uname -a shows old kernel, but rpm -qa shows newer package.

This is exactly your case, citation:
root@puma04 ~]# rpm -qa | grep kernel 
kernel-2.6.32-431.el6.x86_64
libreport-plugin-kerneloops-2.0.9-19.el6.x86_64
kernel-2.6.32-420.el6.x86_64
....
[root@puma04 ~]# uname -a
Linux puma04.scl.lab.tlv.redhat.com 2.6.32-420.el6.x86_64 #1 SMP Mon Sep 23 11:00:49 ...

"It seems the message is there, also we have two kernels installed why ?"
Answer: When new kernel package is installed, usually old stays as fallback in case the new one will fail to boot.

Setting back to ON_QA. First update kernel (with all necessary repos installed first), reboot and then run packstack. If rpm -qa shows the same newest kernel package as uname do, then this bug fails qa ... otherwise set to verified.
Comment 8 Martin Magr 2013-12-06 08:30:35 EST
... and just to be sure: also if the reboot message is shown
Comment 9 Ofer Blaut 2013-12-08 08:58:05 EST
You are correct,
i have updated the kernel rebooted the hosts and installed packstack , no message appear
Comment 12 errata-xmlrpc 2013-12-19 19:29:57 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1859.html

Note You need to log in before you can comment on or make changes to this bug.