Bug 1021226 - Nova Cert service failed to start due to missing hard dependency
Nova Cert service failed to start due to missing hard dependency
Status: CLOSED DUPLICATE of bug 1021405
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-nova (Show other bugs)
4.0
Unspecified Linux
unspecified Severity high
: ---
: 4.0
Assigned To: David Ripton
Ami Jeain
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-20 09:54 EDT by Nir Magnezi
Modified: 2014-06-18 04:59 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-30 06:26:48 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
nova cert log (5.02 KB, text/plain)
2013-10-20 09:56 EDT, Nir Magnezi
no flags Details

  None (edit)
Description Nir Magnezi 2013-10-20 09:54:50 EDT
Description of problem:
=======================
I installed nova-cert service as a standalone node (Via packstack).
It fails to start with a missing import:

 ImportError: No module named cinderclient

Version-Release number of selected component (if applicable):
=============================================================
puddle: 2013-10-15.1

openstack-nova-common-2013.2-0.25.rc1.el6ost.noarch
openstack-nova-cert-2013.2-0.25.rc1.el6ost.noarch

How reproducible:
=================
Always

Steps to Reproduce:
===================
1. Install OpenStack via packstack, Make sure that the node you configure to run nova-cert service is only used with CONFIG_NOVA_CERT_HOST.

2. Via CLI, check nova-cert service status:
   # service openstack-nova-cert status

3. Check nova-cert log

Actual results:
===============
nova-cert status:
openstack-nova-cert dead but pid file exists

nova-cert log:

2013-10-20 16:37:56.590 7430 CRITICAL nova [-] No module named cinderclient

Expected results:
=================
nova-cert should be up and running post installation.

Additional Info:
================
To work around the issue:
1. install python-cinderclient
   # yum install python-cinderclient

2. and restarted the nova-cert service.
   # service openstack-nova-cert restart
Comment 1 Nir Magnezi 2013-10-20 09:56:17 EDT
Created attachment 814221 [details]
nova cert log
Comment 3 Xavier Queralt 2013-10-30 06:26:48 EDT
This bug is caused by the same problem in bug 1021405, closing as a duplicate.

*** This bug has been marked as a duplicate of bug 1021405 ***

Note You need to log in before you can comment on or make changes to this bug.