Bug 1021234 - cheese don't run
cheese don't run
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: cheese (Show other bugs)
20
i686 Linux
unspecified Severity low
: ---
: ---
Assigned To: Matthias Clasen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-20 12:36 EDT by Łukasz Posadowski
Modified: 2014-09-10 13:32 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-09-10 13:32:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Łukasz Posadowski 2013-10-20 12:36:44 EDT
Description of problem:
Cheese doesn't start. Even cheese --help, or cheese --version don't work. It doesn't give any message, just hangs consuming 100% CPU.

I tried to rebuild srpm package, but it hangs as well on this part:
cd ./docs/reference && make  all
make[3]: Entering directory `/root/rpmbuild/BUILD/cheese-3.10.0/docs/reference'
  GEN      cheese.1
Note: Writing cheese.1
make[3]: Leaving directory `/root/rpmbuild/BUILD/cheese-3.10.0/docs/reference'
and also consuming 100% of CPU.


Version-Release number of selected component (if applicable):
$ rpm -q cheese
cheese-3.10.1-1.fc20.i686

How reproducible:
always

Steps to Reproduce:
1. run cheese
2. wait until cpu is overheat
3.

Actual results:
cheese doesn't run

Expected results:
run cheese

Additional info:
Camera on my laptop (Microdia Sonix Integrated Webcam) works with vlc.
Comment 1 Łukasz Posadowski 2013-10-21 02:21:54 EDT
Totem (movie player) doesn't working, too. And also hangs on
totem --version
Comment 2 Przemysław Palacz 2013-10-21 06:43:36 EDT
What version of taglib do you have installed?
Comment 3 Łukasz Posadowski 2013-10-21 14:05:17 EDT
(In reply to Przemysław Palacz from comment #2)
> What version of taglib do you have installed?

# rpm -q taglib
taglib-1.9.1-1.fc20.i686


I checked some things. As silly as it may sound it's Nvidia drivers fault. But cheese and totem run smoothly with nvidia drivers on Fedora 19. I tried to build modules using akmodsbuild from rpmfusion and rebuilding while nvidia-kmod srpm from them and it did nothing.

I would understand window to crash, or buggy blue background in a movie, but "totem/cheese --version"? It should just send some test to stdout, what a display driver could possibly break?
Comment 4 Łukasz Posadowski 2013-10-21 14:10:37 EDT
(In reply to Łukasz Posadowski from comment #3)

while -> whole
test -> text
sorry for the typos
Comment 5 Łukasz Posadowski 2013-11-09 10:20:52 EST
Well, it works now. I don't know why.

Thanks.
Comment 6 Pierre Juhen 2014-01-04 03:45:18 EST
Cheese loops endlessly in init phase.

It seems to deadlock itself; hereafter is a gdb trace :

#0  0x00000031d8c0b1fe in pthread_mutex_unlock () from /lib64/libpthread.so.0                                                                                                                                                                
#1  0x00000031d7801099 in tls_get_addr_tail () from /lib64/ld-linux-x86-64.so.2                                                                                                                                                              
#2  0x000000320fa10d0e in getprocattrcon_raw () from /lib64/libselinux.so.1                                                                                                                                                                  
#3  0x000000320fa0aa6e in is_selinux_enabled () from /lib64/libselinux.so.1                                                                                                                                                                  
#4  0x0000003fafca5da6 in ?? () from /usr/lib64/nvidia-304xx/libGL.so.1                                                                                                                                                                      
#5  0x0000003fafc8505b in ?? () from /usr/lib64/nvidia-304xx/libGL.so.1                                                                                                                                                                      
#6  0x00000031d780f2dd in call_init.part.0 () from /lib64/ld-linux-x86-64.so.2                                                                                                                                                               
#7  0x00000031d780f403 in _dl_init_internal () from /lib64/ld-linux-x86-64.so.2                                                                                                                                                              
#8  0x00000031d780122a in _dl_start_user () from /lib64/ld-linux-x86-64.so.2                                                                                                                                                                 
#9  0x0000000000000001 in ?? ()                                                                                                                                                                                                              
#10 0x00007fffffffe0ce in ?? ()                                                                                                                                                                                                              
#11 0x0000000000000000 in ?? ()                                                                                                                                                                                                              
(gdb) continue                                                                                                                                                                                                                               
Continuing.                                                                                                                                                                                                                                  
^C                                                                                                                                                                                                                                           
Program received signal SIGINT, Interrupt.                                                                                                                                                                                                   
0x00000031d8c09ff3 in pthread_mutex_lock () from /lib64/libpthread.so.0                                                                                                                                                                      
(gdb) bt
#0  0x00000031d8c09ff3 in pthread_mutex_lock () from /lib64/libpthread.so.0
#1  0x00000031d7801069 in tls_get_addr_tail () from /lib64/ld-linux-x86-64.so.2
#2  0x000000320fa10d0e in getprocattrcon_raw () from /lib64/libselinux.so.1
#3  0x000000320fa0aa6e in is_selinux_enabled () from /lib64/libselinux.so.1
#4  0x0000003fafca5da6 in ?? () from /usr/lib64/nvidia-304xx/libGL.so.1
#5  0x0000003fafc8505b in ?? () from /usr/lib64/nvidia-304xx/libGL.so.1
#6  0x00000031d780f2dd in call_init.part.0 () from /lib64/ld-linux-x86-64.so.2
#7  0x00000031d780f403 in _dl_init_internal () from /lib64/ld-linux-x86-64.so.2
#8  0x00000031d780122a in _dl_start_user () from /lib64/ld-linux-x86-64.so.2
#9  0x0000000000000001 in ?? ()
#10 0x00007fffffffe0ce in ?? ()
#11 0x0000000000000000 in ?? ()
(gdb) 


cheese stays in pthread mutex  lock / unlock of the nvidia driver.

Tested today on Fedora 20 with kernel 3.12.6-300.fc20.x86_64.

Thank you,
Comment 7 fab 2014-08-21 06:06:01 EDT
Hello
I'm experiencing extacly the same problem on fedora 20/mate with nvidia drivers.
Did you found any workaround ?
Thanks.
Comment 8 David King 2014-09-10 13:32:15 EDT
If this problem affects both Cheese and Totem, it is probably due to an interaction between the proprietary nVidia driver and Clutter, which is used by both. If you can debug this further, it is probably worth filing a bug with nVidia with the details.

Note You need to log in before you can comment on or make changes to this bug.