Bug 1021239 - Enhancement request: perl-Gtk2 [NEEDINFO]
Enhancement request: perl-Gtk2
Status: CLOSED ERRATA
Product: Fedora EPEL
Classification: Fedora
Component: perl-Gtk2 (Show other bugs)
el6
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tom "spot" Callaway
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-20 13:13 EDT by Dave M
Modified: 2013-11-08 12:58 EST (History)
2 users (show)

See Also:
Fixed In Version: perl-Glib-1.280-4.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-08 12:58:40 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
davem: needinfo?


Attachments (Terms of Use)

  None (edit)
Description Dave M 2013-10-20 13:13:41 EDT
Description of problem:
The current version of perl-Gtk2 is severely outdated - currently years out of date.  It is missing a great deal of bug fixes and improvements.

Version-Release number of selected component (if applicable):
perl-Gtk2-1.224-2

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Please consider updating to a newer version.  Newer versions bring a great deal of bug fixes and improvements.   Fedora currently has perl-Gtk2-1.247-1, which is considered stable.  I do realize the EPEL series isn't meant for latest and greatest.
Comment 1 Fedora Update System 2013-10-23 18:27:37 EDT
perl-Glib-1.280-4.el6,perl-Gtk2-1.248-1.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/perl-Glib-1.280-4.el6,perl-Gtk2-1.248-1.el6
Comment 2 Fedora Update System 2013-10-24 15:08:45 EDT
Package perl-Glib-1.280-4.el6, perl-Gtk2-1.248-1.el6:
* should fix your issue,
* was pushed to the Fedora EPEL 6 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing perl-Glib-1.280-4.el6 perl-Gtk2-1.248-1.el6'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2013-11937/perl-Glib-1.280-4.el6,perl-Gtk2-1.248-1.el6
then log in and leave karma (feedback).
Comment 3 Dave M 2013-10-26 11:10:13 EDT
Hi,

Further testing shows this build may be missing some files.  For example, this build should have Gtk2::Spinner, but it doesn't:

[dave@centos ~]$ perl -MGtk2=-init -E 'my $a = Gtk2::Spinner->new'
Can't locate object method "new" via package "Gtk2::Spinner" (perhaps you forgot to load "Gtk2::Spinner"?) at -e line 1.

Or try

rpm -ql perl-Gtk2 |grep -i spinner

No results.

The build logs show that this build "provides" Gtk2::Spinner, but I'm unable to use it.  I'm going to compare spec files from this and the Fedora builds and see if something is different.

Can anyone verify this?

Thanks,
Dave M
Comment 4 Fedora Update System 2013-11-08 12:58:40 EST
perl-Glib-1.280-4.el6, perl-Gtk2-1.248-1.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.