Bug 1021273 - apache-sshd-0.9.0 breaks ovirt-engine host-deploy
apache-sshd-0.9.0 breaks ovirt-engine host-deploy
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: apache-sshd (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Juan Hernández
Fedora Extras Quality Assurance
infra
:
: 1033706 (view as bug list)
Depends On: 1013333
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-20 17:45 EDT by Alon Bar-Lev
Modified: 2013-12-16 18:12 EST (History)
12 users (show)

See Also:
Fixed In Version: apache-sshd-0.9.0-3.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-16 18:12:16 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 21769 None None None Never
oVirt gerrit 21771 None None None Never

  None (edit)
Description Alon Bar-Lev 2013-10-20 17:45:36 EDT
2013-10-21 00:43:48,401 ERROR [org.ovirt.engine.core.bll.VdsDeploy] (VdsDeploy) Error during deploy dialog: java.io.IOException: Unexpected connection termination
        at org.ovirt.otopi.dialog.MachineDialogParser.nextEvent(MachineDialogParser.java:388) [otopi.jar:]
        at org.ovirt.otopi.dialog.MachineDialogParser.nextEvent(MachineDialogParser.java:405) [otopi.jar:]
        at org.ovirt.engine.core.bll.VdsDeploy._threadMain(VdsDeploy.java:750) [bll.jar:]
        at org.ovirt.engine.core.bll.VdsDeploy.access$1800(VdsDeploy.java:77) [bll.jar:]
        at org.ovirt.engine.core.bll.VdsDeploy$45.run(VdsDeploy.java:893) [bll.jar:]
        at java.lang.Thread.run(Thread.java:724) [rt.jar:1.7.0_40]
Comment 1 Alon Bar-Lev 2013-10-20 17:58:24 EDT
apache-sshd-0.7.0 - works
apache-sshd-0.8.0 - works
Comment 2 Alon Bar-Lev 2013-11-27 05:09:58 EST
*** Bug 1033706 has been marked as a duplicate of this bug. ***
Comment 3 Alon Bar-Lev 2013-11-27 05:37:12 EST
it cannot be target release 3.3.2 as it is not really to be solved.
fix will be achieved only when we have working package in fedora, either by fedora downgrade to 0.8.0 or upgrade to fixed version of the package.
Comment 4 Alon Bar-Lev 2013-11-27 05:41:38 EST
Removing from ovirt project as it is a fedora issue from now.
Comment 5 Alon Bar-Lev 2013-11-27 05:42:55 EST
I suggest to downgrade non working package in fedora to apache-sshd-0.8.0.

In the mean time we added a workaround to provide our own jar.

Thanks,
Comment 6 Fedora Update System 2013-11-27 08:59:47 EST
apache-sshd-0.9.0-3.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/apache-sshd-0.9.0-3.fc19
Comment 7 Juan Hernández 2013-11-27 09:01:49 EST
Downgraded to 0.8.0 as requested. However the version number can't go backwards so it stays at 0.9.0, only the release number changed. Should you need to require this version do as follows:

  Require: apache-sshd >= 0:0.9.0-3

This time please test and vote the package while it is in testing.
Comment 8 Alon Bar-Lev 2013-11-27 09:13:11 EST
I am not fedora/rpm native... but isn't there any way to mask bad packages for users? many problems can be found post publish, and the need to revert is not far fetched.
Comment 9 Juan Hernández 2013-11-27 09:16:14 EST
There is no way to automatically revert a package that is already installed in user system, the only way is to move forward, either changing the release number or the epoch.
Comment 10 Alon Bar-Lev 2013-11-27 10:14:14 EST
(In reply to Juan Hernández from comment #9)
> There is no way to automatically revert a package that is already installed
> in user system, the only way is to move forward, either changing the release
> number or the epoch.

worth considering adding that feature, similar to package.mask of gentoo, just a thought.
Comment 11 Fedora Update System 2013-11-29 01:59:18 EST
Package apache-sshd-0.9.0-3.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing apache-sshd-0.9.0-3.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-22323/apache-sshd-0.9.0-3.fc19
then log in and leave karma (feedback).
Comment 12 Fedora Update System 2013-12-16 18:12:16 EST
apache-sshd-0.9.0-3.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.