Bug 1021311 - Gadget server to default with tab and gadgets
Gadget server to default with tab and gadgets
Status: CLOSED WONTFIX
Product: JBoss Fuse Service Works 6
Classification: JBoss
Component: RT Governance (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Julian Coleman
Jiri Sedlacek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-20 23:33 EDT by Catherine Robson
Modified: 2015-08-02 19:45 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
When the user first loads the RT Governance console, it is blank. There is a risk that users might not see the "+" button because it is small. This presents a usability problem.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-26 14:44:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Catherine Robson 2013-10-20 23:33:31 EDT
Description of problem:
When the user first comes to the RT Governance part of the console, it is blank and users might miss the + button to add a dashboard since it is so slight.  With very few widgets, it seems we can provide a default to get users started from.

Recommended solution:
For version 6.0.0 of this product, there are only 4 widgets the users can work with.  Out of the box, we should have a default dashboard ('Dashboard' is a fine name) with the 4 widgets pre-loaded upon first visiting.  Users can then add more dashboards or widgets as desired.  This will prevent some work on the users end from a first use standpoint and leaves the user with a suggested page rather than an empty canvas to start with.
Comment 2 Gary Brown 2013-10-22 12:14:24 EDT
This requires a change to the installer (database configuration). Currently the installer inserts the gadgets into the gadgetserver db - the additional sql statements to preconfigure the first page are defined here:

https://github.com/Governance/rtgov/commit/d46ccef6247a2793a9c4296a68be0f212277105c

Reassigning to productization to make the necessary changes to the installer.
Comment 3 kconner 2014-06-26 14:44:51 EDT
Gadget Server is being replaced by the new RTGov UI

Note You need to log in before you can comment on or make changes to this bug.